Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Serial Problems with 512

  1. #1
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default Serial Problems with 512

    Since updating from 510 to 512 I'm having serial problems.

    If two serial commands are sent too quickly to my Meridian receiver the response is coming back corrupted, and the 2nd doesn't get actioned, at other times it's freezing comms and I have to rest the LUA (F11) to get it working again.

    This is the log if I run the two commands in the macro (Select CDR input, then set volume to 57) manually using F5

    Code:
    Received Meridian Response: 
    Meridian Response Length = 0
    Received Meridian Response: CDR     45
    Meridian Response Length = 12
    Returned prefix: CDR
    Meridian Volume Received = 45
    Meridian500: Publishing event Processor 45
    Got Meridian500 Event: nil Volume 45
    Device id:  Processor
    Meridian500: Publishing event Processor Off
    Got Meridian500 Event: nil Mute Off
    Device id:  Processor
    Meridian Provider Received Volume Value 57
    Received Meridian Response: VN57
    Meridian Response Length = 4
    Received Meridian Response: Music     57
    Meridian Response Length = 12
    Returned prefix: Music
    Meridian Volume Received = 57
    Meridian500: Publishing event Processor 57
    Got Meridian500 Event: nil Volume 57
    Device id:  Processor
    Meridian500: Publishing event Processor Off
    Got Meridian500 Event: nil Mute Off
    Device id:  Processor
    If I run the full macro I get this instead, notice the corrupt response in bold, this is all I get.

    Code:
    Meridian Provider Received Volume Value 57
    Received Meridian Response: 
    Meridian Response Length = 0
    Received Meridian Response: Longe   @j8
    Meridian Response Length = 12
    Often I get this response (below) and then I have to reset (F11) to get control back. In this one I ran the macro once then two more times and as you can see comms stopped with the serial device after the first run.

    Code:
    Meridian Provider Received Volume Value 57
    Received Meridian Response: 
    Meridian Response Length = 0
    Received Meridian Response: Longe    U8
    Meridian Response Length = 12
    Meridian Provider Received Volume Value 57
    Received Meridian Response: 
    Meridian Response Length = 0
    Meridian Provider Received Volume Value 57
    I've tried S, H and N for flow control. S & N give the same H doesn't work at all.

    I can fix the problem with a 2 second wait in the macro between commands, but I never had the comms freeze with 510 and really didn't want waits in there as it slows things down.

    Provider and serial files attached.

    Any suggestions?

    Cheers
    Richard
    Attached Files Attached Files

  2. #2
    Join Date
    Sep 2001
    Location
    London
    Posts
    312

    Default

    I'm also experiencing what seems to be the same issue with both my projector and receiver (I haven't tested with 510, but the scripts for my Rotel RSX-1055 and Sony 10HT don't show this issue with Girder 4.x)

    If this can be of any help, the serial plugin call back function returns serial.INCOMPLETERESPONSETIMEOUT

  3. #3
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    Even with waits in the macro I'm still getting serial hangs, and it seems worse when I send commands to both my serial devices.

    But it'd always the Meridian port that stops responding and needs the lua reset.

    Richard

  4. #4
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    12,500

    Default

    I'm looking into this.
    Ron
    No support through PM

  5. #5
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    12,500

    Default

    Give this dll a try. Since I don't have the hardware you guys have I don't know if my fixes did the trick. Unzip in the plugins directory.
    Last edited by Ron; February 6th, 2007 at 05:48 PM.
    Ron
    No support through PM

  6. #6
    Join Date
    Sep 2001
    Location
    London
    Posts
    312

    Default

    Thanks Ron,

    This seems to work somewhat better:

    I still get quite a few errors of the same type (basically every other call back flags this error) although the good messages from my receiver do get through somehow this time.

    I also noticed that now, there is a serial error #65536 on two of my serial devices (including a 'one-way' VFD).

    Eiffel

  7. #7
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    Quote Originally Posted by Ron View Post
    Give this dll a try. Since I don't have the hardware you guys have I don't know if my fixes did the trick. Unzip in the plugins directory.
    Doen't seem to haev helped here I'm afraid.

    Maybe my plugin isn't handling things properly, not sure but the port is still freezing.

    Richard

  8. #8
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    12,500

    Default

    @Eiffel 65536 is the 'connect' message. This is not an error. Also please be more specific what other errors you get.

    @Richard, please be more specific what you mean by freeze and what happens before it freezes or what you have to do to make it freeze.

    btw that plugin up there only has 1 download. So one of you two did actually not get the updated file :-)
    Last edited by Ron; February 6th, 2007 at 05:49 PM.
    Ron
    No support through PM

  9. #9
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    12,500

    Default

    Here is a the plugin that reports version # 1.0.0.2
    Attached Files Attached Files
    Ron
    No support through PM

  10. #10
    Join Date
    Sep 2001
    Location
    London
    Posts
    312

    Default

    Ron,

    Sorry I should have been more explicit, the errors I receiver are #8192 (serial.INCOMPLETERESPONSETIMEOUT)

    Otherwise, glad to read that the other error is in fact the connect message which I hadn't seen before (What's surprising then is that I don't see such message with my projector)

    Eiffel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •