Results 1 to 9 of 9

Thread: gwes.exe crashes on PPC with .91

Hybrid View

  1. #1
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default gwes.exe crashes on PPC with .91

    .91 seems to be crashing gwes.exe on my PPC (Dell Axim x51v) a lot more than previous version, although I still got some crashes with earlier versions.

    If I load a new CCF, either mine of one of the default ones I often get a gwes.exe crash with .91.

    I also get gwes.exe crashes at other time too while using the remote.

    Here's what's in the error report:
    Code:
    Bucket Parameters
    ==============
    EvntType: WinCE501bException
    AppName: gwes.exe
    AppVer: 5.1.0.0
    AppStamp: a5ae002b
    ModName: webview.dll
    ModVer: 5.1.0.0
    MosStamp: b463eab7
    Offset: 0004c750
    OwnName: NetRemote.exe
    OwnVer: 2.0.0.91
    OwnStamp: 460748b0
    The NetRemote Log has this;
    Code:
    07:09:34.750803] ScriptEngine] INIT: Loading hotkeys
    07:09:34.750825] ScriptEngine] Couldn't load pronto font resource
    07:09:34.750829] ScriptEngine] INIT: Loading drivers
    07:09:35.750836] ScriptEngine] \Program Files\NetRemote\plugins\drv_nrbasic.dll
    07:09:35.750931] ScriptEngine] \Program Files\NetRemote\plugins\drv_MediaBridge.dll
    07:09:35.751114] ScriptEngine] \Program Files\NetRemote\plugins\drv_ir.dll
    07:09:35.751244] ScriptEngine] \Program Files\NetRemote\plugins\drv_wol.dll
    07:09:35.751340] ScriptEngine] \Program Files\NetRemote\plugins\drv_webbrowser.dll
    07:09:35.751495] ScriptEngine] \Program Files\NetRemote\plugins\drv_girder.dll
    07:09:35.751640] ScriptEngine] \Program Files\NetRemote\plugins\drv_flash.dll
    07:09:35.751809] ScriptEngine] \Program Files\NetRemote\plugins\drv_generic.dll
    07:09:36.751939] ScriptEngine] \Program Files\NetRemote\plugins\drv_avidutils.dll
    07:09:36.751988] ScriptEngine] \Program Files\NetRemote\plugins\drv_zoom.dll
    07:09:36.752035] ScriptEngine] INIT: Getting skin filename
    07:09:36.752044] ScriptEngine] INIT: Attempting to load ccf
    07:09:45.760992] ScriptEngine] Creating CCF object
    07:09:45.761021] ScriptEngine] Enabling callbacks
    07:09:45.761025] ScriptEngine] Initializing lua
    07:09:46.762399] ScriptEngine] INIT: CCF Loaded
    07:09:46.762408] ScriptEngine] Creating default instance -1018
    07:09:46.762431] ScriptEngine] htpc1 => 192.168.1.11 (Direct)
    07:09:46.762497] ScriptEngine] Creating default instance -1014
    07:09:46.762503] ScriptEngine] Creating default instance -999
    07:09:46.762507] ScriptEngine] Creating instance -30
    07:09:46.762512] ScriptEngine] Created instance -30
    07:09:46.762516] ScriptEngine] Creating instance -2001
    07:09:46.762617] ScriptEngine] Created instance -2001
    07:09:46.762623] ScriptEngine] Creating instance -2
    07:09:46.762634] PluginSocket [WebServer:-2]] Starting server listen thread
    07:09:46.762637] WebServer] Web server started on 15000
    07:09:46.762640] ScriptEngine] Created instance -2
    07:09:46.762643] ScriptEngine] Creating instance -4
    07:09:46.762645] ScriptEngine] Created instance -4
    07:09:46.762651] ScriptEngine] Creating instance -3
    07:09:46.762693] PluginSocket [Girder:-2001]] TCP/IP Socket connected (attempting handshake)
    07:09:46.762730] PluginSocket [Girder:-2001]] Handshake successful - socket connected
    07:09:46.762732] PluginSocket [Girder:-2001]] Socket connected
    07:09:47.763367] PluginSocket [WebServer:-2]] Entered server listen thread
    07:09:47.763530] Infrared] Initializing socket
    07:09:47.763533] ScriptEngine] Created instance -3
    07:09:47.763540] ScriptEngine] Creating instance -10
    07:09:47.763731] ScriptEngine] Created instance -10
    07:09:48.764051] ScriptEngine] Creating instance -2010
    07:09:48.764139] ScriptEngine] Created instance -2010, but discarded as duplicate
    07:09:48.764165] MediaBridge] Deleting socket
    07:09:48.764168] MediaBridge] Destructor start -2010
    07:09:48.764170] MediaBridge] End of destructor
    07:09:48.764178] ScriptEngine] Setting current
    07:09:48.764184] ScriptEngine] Done setting current
    07:09:49.765504] WebBrowser] Registering  browser : WEB1
    07:09:49.765778] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:09:49.765782] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:09:49.765788] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:09:52.767969] ScriptEngine] Total time : 3449
    07:09:57.773406] WebBrowser] Registering  browser : WEB1
    07:09:57.773424] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:09:57.773428] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:09:57.773431] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:09:57.773791] WebBrowser] Unregistering browser : WEB1
    07:09:58.774301] ScriptEngine] Total time : 1254
    07:10:00.776442] WebBrowser] Registering  browser : WEB1
    07:10:01.776871] WebBrowser] Registering  browser : WEB1
    07:10:01.776888] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:10:01.776893] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:10:01.776897] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:10:01.777325] WebBrowser] Unregistering browser : WEB1
    07:10:06.782550] ScriptEngine] Total time : 6079
    07:10:07.783253] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:10:07.783255] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:10:07.783258] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:10:08.783870] WebBrowser] Unregistering browser : WEB1
    07:10:13.789276] ScriptEngine] Total time : 13883
    07:10:31.807206] WebBrowser] Unregistering browser : WEB1
    07:10:31.807247] ScriptEngine] Creating CCF object
    07:10:31.807264] ScriptEngine] Enabling callbacks
    07:10:31.807269] ScriptEngine] Initializing lua
    07:10:32.808689] WebBrowser] Registering  browser : WEB1
    07:10:32.808747] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:10:32.808750] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:10:32.808753] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:10:33.808960] ScriptEngine] Total time : 798
    07:10:33.808961] ScriptEngine] Calling OnCCFLoad
    07:10:33.809140] WebBrowser] Registering  browser : WEB1
    07:10:33.809155] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:10:33.809157] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:10:33.809161] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:10:33.809301] WebBrowser] Unregistering browser : WEB1
    07:10:33.809340] ScriptEngine] Total time : 377
    07:10:55.831512] WebBrowser] Unregistering browser : WEB1
    07:10:55.831556] ScriptEngine] Creating CCF object
    07:10:55.831572] ScriptEngine] Enabling callbacks
    07:10:55.831579] ScriptEngine] Initializing lua
    07:10:58.833860] WebBrowser] Registering  browser : WEB1
    07:10:58.833920] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:10:58.833923] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:10:58.833926] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:10:58.834351] ScriptEngine] Total time : 1136
    07:10:58.834353] ScriptEngine] Calling OnCCFLoad
    07:10:59.835082] WebBrowser] Registering  browser : WEB1
    07:10:59.835098] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:10:59.835101] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:10:59.835104] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:10:59.835363] WebBrowser] Unregistering browser : WEB1
    07:11:06.842692] ScriptEngine] Total time : 8331
    07:11:07.843069] WebBrowser] Registering  browser : WEB1
    07:11:08.843913] ScriptEngine] IBrowser implementation does not provide _DPIEWebBrowserEvents2 connection point!
    07:11:08.843917] WebBrowser] Created CLSID_Browser or CLSID_BrowserWM5
    07:11:08.843921] WebBrowser] Initial URL: file://\Program Files\NetRemote\docs\index.html
    07:11:08.844284] WebBrowser] Unregistering browser : WEB1
    07:11:13.849462] ScriptEngine] Total time : 6764

    Removing the web browser plugin from the directory seems to stop the crashes.

    Richard

  2. #2
    Join Date
    May 2002
    Location
    CT
    Posts
    6,559

    Default

    How often did this bomb before, and how often is it happening now?

  3. #3
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    Quote Originally Posted by Ben S View Post
    How often did this bomb before, and how often is it happening now?
    It used to bomb maybe once every couple of days during general use, NR would pause for a few seconds after I select a page and then the error comes up, sometimes it would return to NR after the error other time NR would close.

    If it returned to NR I'd usually get the original page and the selected page overlayed somehow,, wierd look, so I'd reset PPC and start again.

    With .91 I can get it to crash almost every time I open a CCF file, haven't used it long enough to see if it crashes during general use yet.

    Removing the web plugin seems to have stopped the loading crash.

    R

  4. #4
    Join Date
    May 2002
    Location
    CT
    Posts
    6,559

    Default

    I'll investigate. Thanks for the feedback. I'm working on changing the automated build so I can add a PPC2k3 / WM5 specific build to the mix, and may have missed a setting for the web browser plugin.

  5. #5
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    Ben,

    Just letting you know that with the web plugin removed I have not had one NR crash since.

    R

  6. #6
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    Ben,

    I'm still having issues with this in .95, same as mentioned above.

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •