Results 1 to 8 of 8

Thread: MediaBridge Start Up Timing Error

  1. #1
    Join Date
    Jul 2006
    Location
    Mountain View, CA
    Posts
    175

    Default MediaBridge Start Up Timing Error

    About 50% of the time following a reboot of my server, MediaBridge (2.2.0.83) completes booting up before JRMC (12.0.318) completes booting up. When this happens, obviously MediaBridge can't find the Media Player and produces a bunch of error windows.

    This happens despite the fact that I have the box check in the MediaBridge plugin config paged to "Wait forever for player to start (Never error on dleayed start)".

    Isn't this problem what this MediaBridge plugin config item is suppose to prevent?
    If so, is this a bug?

    Thanks

    Dudley

  2. #2
    Join Date
    Feb 2007
    Location
    Cedar Park, TX
    Posts
    15

    Default

    Ditto, same problem.

  3. #3
    Join Date
    Jul 2006
    Location
    Mountain View, CA
    Posts
    175

    Default

    Any feedback on how to get the MediaBridge plugin config button "Wait forever for player to start (Never error on delayed start)" to work or, failing that, how to speed up the boot up of MediaBridge so that it reliably finishes before JRMC finishes booting?

    thanks

    Dudley

  4. #4
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    I used to have the same problem, along with the other one where MB drops the connection if you unload and then reload JRMC.

    I also run Girder, so now my scripts launch JRMC and then wait for this to load before loading Mediabridge, if JRMC isn't loaded then girder unloads MB and then loads JRMC/MB.

    Easy with Girder, but better if MB could handle it itself!


    Richard

  5. #5
    Join Date
    Jul 2006
    Location
    Mountain View, CA
    Posts
    175

    Default

    Thanks Richard. Could you share what file you modified and what the script was that you added to it to do this?

    Thanks

    Dudley

    (Unfortunately I am not proficient in lua.)

  6. #6
    Join Date
    Jul 2005
    Location
    Sydney, Australia
    Posts
    566

    Default

    I just use the standard Girder actions and conditionals to do this.

    I did it for three reasons.
    1) I load MC with my library READ ONLY and MB won't do this
    2) The timeout problem if MB tries to load MC 12
    3) The problem when MC closes and MB drops its connection.

    I have attached an example gml file, the Load Media Players gets triggered every time Girder loads, and I also call it from NetRemote whenever I press a button to do something that requires MC/MB operational (Listen to Music, Play Video, Watch TV etc)

    Probably better/cleaner ways to do this, but hey it works for me and didn't require LUA coding!

    Hope this helps.

    Richard
    Attached Files Attached Files

  7. #7
    Join Date
    Jul 2006
    Location
    Mountain View, CA
    Posts
    175

    Default

    Thanks for the detailed guidance. I'll give it a try.

    Dudley

  8. #8
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    12,478

    Default

    I can confirm that the Media Bridge goes into a funk when JRMC12 is closed from underneat it. I will try to reproduce the startup issue as well and then try to get to the cause of it.
    Ron
    No support through PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •