View Full Version : girder only reconizes 1st command from remote via UIRT2

March 6th, 2005, 04:24 PM
ive now built my 4th uirt2 over the years for my new media pc, but i'm now having problems with my media pc's com port.

the board is a foxconn board 865 chipset, when running girder only the first remote IR command is recognized, after that any remote IR codes just dont reach girder, only after a reboot will girder respond to the IR code, and only for the first code.

the interface is not at fault, it works on all of my other PC's, and the media pc's OS is not at fault because i have a usb-serial interface, which works on the media PC with the UIRT2.
the M/B for the media pc only has 1 com port, and using an external USB-serial converter kind of defeats the point of having an all in one media PC. ive tried com port speeds, resources.... bascially anything i can think of that might be causing a problem with the port.

has anyone else had a similar problem with this type of M/B, or girder only recognising the first IR code ??? the UIRT2 transmits codes ok btw



March 8th, 2005, 10:35 PM
Since you have other UIRT2, is it possible to swap one of the existing ones that works for the new one? That would be an easy test to isolate if the UIRT2 has receiving problems.

In Girder, there is an option to have the Girdericon flash when it gets commands. If you turn this on you might get another indication if Girder, via the UIRT2 driver, is getting the IR signal.

March 9th, 2005, 07:17 AM
all my other UIRT's have the same problem on this machine.....

i'm aware of the led flash in girder, i allways have it on, as i said, girder receives the 1st IR command, but none after that

i went one step further last night and installed a com port monitor, it seems once the UITR has sent girder the 1st bunch of data about the IR signal, then no response is given, so basically the UIRT then keeps sending a request every 15 seconds or so and waiting for a reply, that it doesnt get....

i am under the impresion its got something to do with the super I/O device on this motherboard which the comport works through....

March 9th, 2005, 12:09 PM
well - it does point to the new mobo as the source of the problem. I'll assume you have checked the serial port works as it should with something else plugged into it, like a serial mouse or modem - just to eliminate the serial port as the source. And I'm sure you've checked the Girder settings running on the new mobo.

What about the BIOS settings? Could there be one to set the serial port to "legacy" mode or somthing that would make it more backward compatible. Even though serial is not used as much today, I find it hard to think a new mobo would not be completely support the legacy serial port protocol.

It is possible that the UIRT driver is at fault too. Gather up what you can on the serial port in the new mobo and give Jon Rhees a try as he would be the best expert to answer the actual UIRT2 serial interface. He still checks here now and then but for sure he is at www.usbuirt.com

Whatever you find ou, do post here so we have a status on this issue as it is new to me.

March 9th, 2005, 12:49 PM
Serial Mouse... whats that ?? ; - )

hehehehe , aint seen one of those in years.

yes i have tried other devices, specifically an X10 CMU12, and ive used it to talk to my Dreambox via serial, ive also used the ICSP for the UIRT with success.

since i work for a computer supplier, ive tried 3 moderm m/b's with the 865 chipset, all with the same or similar problems, none of the M/B's have legacy serial options in the bios, ive also tried all the available resource settings for the serial port's.

i have spent hours with this.. and i hold an MCSE, in the end i just gave up and used a Maxxtro usb-serial adapter cable, which works perfectly in the same install of girder, its so frustrating because everything works independently, just not in the specific setup that i want : -(

i will give jon an email, but i have a feeling this new type of fast com port via the super i/o is just evil : -)


March 9th, 2005, 12:59 PM
I wonder if it could be related to the speed of the UIRT2. There were two versions to support the 4mhz and 10mhz crystals. I assume you built them using the faster crystal. Could there be some kind of timing problem in that the UIRT2 is not fast enough to keep up with the super-io port?

That said, since it works via USB, what is the slowest device that the USB port supports since it is able to communicate with the UIRT2?

March 9th, 2005, 01:08 PM
allready ahead of ya....

ive tried, 10mhz pic and xtal, and 4mhz pic and xtal, ive also used 1.7 firmware and 1.8 on both 4mhz and 10mhz variants...

although its interesting to note that girder wont even see the 1st IR string when the 1.7 firware is used.....

weird huh !!!

March 9th, 2005, 01:18 PM

I'm tapped out but -- oh ya -- you are already ahead of me -- the workaround. :D

It's nice to know one can use the USB port for the UIRT2 if they have a lack of a free and working serial port. I still like the feature in the UIRT2 over the USBUIRT but I understand the ease of use advantages of a plug-and-play device.

btw - what's your take on adding additional IR receiver capability to the UIRT2? I recollect Luc felt it would take some effort and not just splicing in a few more IR receivers to the circuit.

March 9th, 2005, 02:29 PM
well the adapter ive used is a bog standard USB to serial adapter, i did enquire about the USB uirt, but it only supports power up via usb, and has no latching outputs for toggling buttons etc.....

so the method of using a USB-serial adapter, means you can keep the serial UIRT2 hardware, but plug it into a usb port.... : -) but you have to supply the UIRT with 5VSB Power and 2 outputs for reset and power on, which makes the whole behind the scenes a cable mess. since my silverstontek case has a side firewire port, that i had no use for, i just modded a firewire cable as the input and power lines into the case

another little tip, the UIRT can be a bit tricky with that whole, pull the Power header + to ground thingy, its much easier to use a 4N25 opto coupler / isolator on the array output, then the PIC can effectively press ANY button. i'm surpised this has never been added to the original design : -) hint hint

the reciever is a tricky situation, i remember emailing the author of the plugin several years ago, about having the capability to have multiple UIRT pluggins enabled, for example to have one UIRT device in one room, and one in another each on a seperate com port (haha). the answer at the time was no, and i recall seeing other posts about adding additional IR receivers to the same circuit was extremely difficult....

my original solution was an isolated repeater, there are many simple pic circuit about for receiving an IR code and re-transmitting it, not an ideal solution, but another workaround.

for simplicity the UIRT uses a built in IR encoder, (built into the TSOP), in theory you could expand the circuit, and use multiple IR reciver diodes, and then use a seperate IR encoder, most 38khz IR encoders can handle MANY IR receiving diodes, but since most people will shortcut and use an all in one receiver/encoder (TSOP) the ouputs of these devices cannot be chained or spliced together.
btw ive found the Mitsumi B0l12 a better UK alternative to the TSOP, since the TSOP can be hard to find here.