PDA

View Full Version : Can't hibernate with the MCE plugin under WinXP Pro



Rik
April 7th, 2005, 03:16 PM
MCE remote is working fine with girder on WinXP Pro, but when I try to hibernate it fails to do so. I receive an error message that explains that windows fails to hibernate because the mceir file won't let it happen. I suppose it's not compatible or something?

Rik

PS: Sorry for the bad english...

Methius
April 12th, 2005, 06:24 AM
I also am trying to use the MCE plugin.

S3 works perfectly, but when I use the MCE plugin w/ drivers I can't go to Suspend (S3).
The Screen just sits at "preparing for standby". And when I press a button on the remote, it goes to suspend for about a microsecond (very quicky in either case), and comes out of S3, but nothing works.

Sagetv hang, MCE receiver doesn't work/MCE plugin receives nothing.

Any help here?

Methius
April 12th, 2005, 07:38 AM
Ok I traced down the problem:

The MCE plugin isnt letting the pc go to standby/hibernate. The remote let's the pc go into suspend perfectly with the modified drivers. But once Girder is started, (with the plugin loaded) the pc doesn't go into suspend.

If you disable the plugin before suspend, it works perfectly. (that is if I disable it manually in the settings)

I made a command to disable the MCE plugin OnSuspend and enable it OnResume.
But it seems the plugin doesn't get disabled fully. Yes, it doesn't receive any commands, but it still hangs the Suspend/Hibernation.

Can the maker of the plugin please look into this matter? (Simply letting it unload from the memory with the disable device/enable device command should work.)

Thanks in advance!!

(I bought the MCE remote for the Blaster funcion & resume from standby, so this means a lot to me ;). BTW, it still resumes from standby, even if the plugin is disabled.)

Rik
April 12th, 2005, 03:50 PM
Exactly my problem. The MCE receiver driver won't let windows go into any suspend mode.

Methius
April 12th, 2005, 03:51 PM
Fixed it.
You can Unload & Load Plugins with LUA (thank god for the search function ;) ).

I'll upload my GML.
Features:
- MCE Remote mapping (All Keys)
- On Suspend ---> 1. Unload MCE Plugin, 2. Send IR Blast (Setup an .bat file for this. I used it to put my TV in standby.)
- OnResumeSuspend ----> 1. Wait 10 sec, 2. Load MCE Plugin , 3. Send IR Blast.

Pretty straight forward, and simple. But it works... Like a charm.
Seems not the drivers were the problem, but the plugin...

Ps. If you have some problems: Reinstall the drivers & plugin, using the drivers from promixis.com (not from thegreenbutton.com). Make sure Girder is disabled! (even for the driver install)

EDIT: PPS.
The MCE remote will wake the PC with the power button :D.
(Have everything I want now:
- Configurable MCE Remote
- IR Blast option
- USB Remote Wake up)

Rik
April 13th, 2005, 05:03 PM
Hmm... even without Girder loaded hibernation won't work. I tried your script but it doesn't help. I even tried to uninstall girder, but when the driver from promixis.com is installed my pc won't hibernate. The original driver works fine, but then I can't use girder.
Any ideas?

Methius
April 13th, 2005, 06:11 PM
Have you tried S3 suspend? It's practically as good as hibernation.

Owh, btw, do you also have the problem that after you use the IR Blast feature of the receiver a couple of times it just stops sending IR Blasts?

(I emulated my TV Remote, but if I use it for a while it just stops working.. The api says the ir is transmitted correctly, but the IR blaster stays off. Only a system off/on works. (Suspend doesn't))

Rik
April 14th, 2005, 05:20 AM
I use the remote in my carpc. If I try s3 suspend my battery will be dead in a few days. With hibernation it won't. I'll try that IR blast thing you mention. I've not really tried it yet, but I'm planning to. Spent all my time to figure out how to get the pc to hibernate with the plugin :wink:

Methius
April 14th, 2005, 10:42 AM
Well I think I found your solution: Devcon http://support.microsoft.com/default.aspx?scid=kb;en-us;311272

Download it, put it in a map (make sure it contains devcon.exe, create 2 .bat files in that map:
on.bat
which contains:
devcon -enable USB\VID_0471*

off.bat
which contains:
devcon -disable USB\VID_0471*

Then make Girder run Off.bat onHibernation and On.bat onResumeHibernation
With Hidden as option. The only draw back is that the remote won't let your PC come out of awake (It wil not awake the pc when the power button is pressed I mean.)

I'm trying to use the remove and install feature of Devcon to completly reinstall the receiver when the IRBlast doesn't work anymore. But I can't get Devcon to install unsigned drivers.
(I've been looking into SetupApi for help, but I don't know anything about that programming so I really need help in that.)

Rik
April 15th, 2005, 12:40 PM
Well, I tried to disable the plugin in girder, exactly the way you wrote but girder still somehow blocks hibernation. The disable/enable function works perfectly when girder isn't loaded but when girder is loaded it doesn't. I guess that girder doesn't completely disable the plugin or something. Weird weird weird........

Methius
April 16th, 2005, 04:36 AM
That is weird..

But, if Girder hasn't loaded the plugin and you have disconnected the receiver, can you go into hibernation then?

If so:
Make these 2 multigroups (start a new GML for testing purpose)
Multigroup Shutdown :
Event: OnHibernation -
Command: +Unload plugin receiver
(Not the disable command from girder, doesn't work. Use the UnLoadPlugin command from LUA. See the GML file, I believe it's under suspend/resume.)
Command: +Run off.bat

Multigroup Startup :
Event : OnResumeHibernation -
Command: Wait 5 sec
Command: + Run on.bat
Command: + Load plugin receiver
(Not the enable command from girder, that doesn't work. Use the LoadPlugin command from LUA. See the GML file I uploaded in this thread, I believe it's under suspend/resume.)


If Girder let's your pc go into Hibernation when the Plugin isn't loaded and you haven't connected/disabled (in Device Manager) the receiver (test this first.), then this should work. It Unloads the plugin and disables the receiver. Also test the off.bat and on.bat file just by running them and check if it really disables the Receiver (in Device Manager).

If it doesn't work after that, try to see if Girder let's you unload the plugin by making a command that unloads the plugin on a certain keypress. Press the key and check if the plugin is unloaded. Hope this helps.

Rik
April 16th, 2005, 01:29 PM
Doesn't work.
DevCon won't disable the driver when girder is loaded. Even with the plugin manually disabled. It only works if I delete the .dll file from the girder plugin directory.
Which is very weird because the plugin shouldn't be loaded at all! :-?

Methius
April 19th, 2005, 07:41 AM
BurningZeRoad (the developer of this plugin) has released a much more stable version of this api on thegreenbutton.com. (See Hacks & Mods Forum)
Post your problem there so you'll be sure he can do something about it :)
(He already mentioned he is working on the hibernation problem, but stil ;) )

Promixis
April 19th, 2005, 07:59 AM
If there is a newer version of the plugin, would someone please upload it here :) !

BurningZeRoad
April 19th, 2005, 02:16 PM
@Mike : Someone uploaded MCEIR version 0.14 ! ;)

@Rik : As Methius ;) mentionned S4 (hibernate) can't be reached with the actual version. But I think (meaning not tested) the workaround he suggested should now work (if you really want to go into hibernate state...).:

OnHibernation : devcon disable "@USB\VID_0471&PID_0815*"
OnHibernationResume : devcon enable "@USB\VID_0471&PID_0815*"

Rik
April 20th, 2005, 05:09 PM
Thanks guys! Got it working! :D I installed the new api and I don't have any problems anymore. With the help of devcon :wink:.
The only problem I now have is that my remote sometimes stops working. I have the MCE 2005 remote. But then I have to take the batteries out for about a half an hour and then it works fine again. But my problem with girder and hibernation seems to be solved. Thanks again!

BurningZeRoad
May 5th, 2005, 10:38 AM
Hi Rik !
You can download MCEIR 0.16 version : I have updated MCEIR driver so it now allows the system to go into hibernate state (and the devcon workaround is no more necessary).
Cheers ! ;)

Shrapnel
May 5th, 2005, 09:11 PM
I have the MCE remote from newegg.com. Ordered it about a year ago. However, I could never install your MCE driver. Upon looking through your inf, I see that our USB devices do not match, thus no driver match, thus no install.

Mine is listed as USB\VID_045E&PID_006D

I tried changing the inf, this got the driver to install. However, Girder still does not work either with or without the driver. When I click learn event, it keeps waiting for IR...

Yes, I have the plugin enabled and have tried .15 and .16

Thanks for writing this and any help that may be offered.

BTW: XP Pro SP2...

BurningZeRoad
May 6th, 2005, 07:29 AM
Hi Shrapnel !
USB\VID_045E&PID_006D is a MCE Remote V1... and the plugin doesn't work with it (only with V2 also called 2005). You can look at Windows\Inf\irbus.inf to check your remote is an IrBus_V2 device then the plugin will work.
I just need having a V1 remote at home for a couple of days to make it work... if someone is interested in my proposal, just PM me ! ;)

alona24
May 9th, 2005, 02:43 AM
Is there a way to make the MCE remote plugin work with Gyration MCE Remote and it Swipes?

BurningZeRoad
May 9th, 2005, 01:44 PM
Sorry but I don't think so... :(
My plugin works with infrared MCE remote controls provided with IR blasters... not RF ones.
As far as I can read in its datasheet, you need a specific software to be able to control MCE : IR MCE remote controls don't...
I think you'd better create a new thread on that subject... maybe someone will hear your request... ;)

Edit: Oups ! Already done ! :D

Rik
May 22nd, 2005, 12:36 PM
Very strange, but I still can't hibernate with the plugin. I've even tried 0.17 but it doesn't make a difference. Any ideas?

antimatter
July 13th, 2005, 12:51 AM
Can you guys tell me exactly what product to buy. I found several different listings and i want to get the one that will work with this plugin. I only found one website that listed these remotes and recievers as you described them "MCE 2005 or V2" and they are out of stock.

Here is the one that i able to deduce was the correct one
http://www.pcalchemy.com/product_info.php/pName/philips-mce-remote-control-for-windows-xp-mce-2005/manufacturers_id/21

Now they also sell the microsoft one that is more expensive
http://www.pcalchemy.com/product_info.php/pName/microsoft-mce-remote-control-for-windows-xp-mce/cName/remote-controls

I am assumming that the microsoft one is the old one.

I also found a few that say MCE 2005 on ebay but they all look like the microsoft one. Can one of you experts clarify this for me.

I want to run it exactly like RIK has his setup i also have a car pc.

antimatter
July 18th, 2005, 12:04 AM
Don't all reply at once
:wink:

Anyways i bought the microsoft one and it worked like a charm. Now i just need to sort out this devcon stuff