PDA

View Full Version : Can't send IR codes with MCE plugin - I'm very confused!



zyll
May 28th, 2005, 01:54 PM
I am trying to use the MCE plugin to send IR, and am very confused.....

I can receive IR codes, and learn from my remote just fine.
I can test the command, and see the IR blaster flash
I can see that the event is supposed to trigger it, but....
Nothing happens when I try to use it!

I am pretty new at Girder, so it may be something silly....
I can see the girder Icon flash when I push the button, but nothing happens.
The logger says that the event was received.

Do I need to set the "target" for the blaster?? Any other ideas? Thanks.....

BurningZeRoad
May 31st, 2005, 03:57 PM
I can't find the silly thing in your description... maybe you should post your GML file so I can see what's wrong with it. ;)

zyll
May 31st, 2005, 04:07 PM
My GML file is attached - I thought that it would be a configuration issue rather than a GML issue. I appreciate your help.....

BurningZeRoad
May 31st, 2005, 07:09 PM
Got it ! :D
Within a Multigroup, an Evenstring is not triggered when it is directly attached to the Command (as child). It seems to be a Girder bug.
You just have to move the Evenstring at the same level as the Command (as sibling) to workaround this issue. ;)

zyll
May 31st, 2005, 09:14 PM
:P
It works! Thanks a lot for taking a look - I really appreciate the help (and the plugin). This plugin is the reason a bought girder, and is helping me overcome some of the shortcomings of MCE - I thought it had to be something simple that I just couldn't see.

I discovered that after creating a new command, Girder will automatically add the eventstring (as a child) when "learn" is pressed, and so that's how these were created.

Thanks again.
Marshal