View Full Version : Performance Problem

December 29th, 2005, 08:44 AM
I am writing a GML for the WinFast PVR TV program.

When this GML file is active, and the WinFast PVR application is running, I expirence a performance problem with Girder.

Key presses on my remote (Remote Wonder I) take 1-2 seconds to be recognozed by WinFast. Doing things like adding actions or events in Girder while WinFast PVR is running, and my GML file is active, is VERY slow.

If I deactivate my GML file, Girder speeds back up to normal.

I have attached the GML file in hopes that someone could look at it and see what I have done wrong. Note that the GML is not complete yet, so please dont pass it around, When/If I get it done I will let everyone know.

December 29th, 2005, 08:54 AM
OK - After some debugging, I have determed that the problem is in the Start Group.

if I delete the Start Group, everything speeds up....

Dont know what I am doing wrong in the Start Group, however, so please take a look at it and let me know.



December 29th, 2005, 08:56 AM
Can you open the logger and see if there are any events coming in? And its only with the GML enabled?

December 29th, 2005, 09:09 AM
Yes, it's only with the GML enabled, and only when the "Start" group is in the definition. If I delete the "Start" group, then everything gets back to normal.

An example of the slow down is when I clicked the checkbox to disable toe GML, it took 5 seconds to respond....

I opened up the l;ogger and the only events I see are when I press remote buttons.

December 29th, 2005, 12:15 PM
Remove the conditional from the start group see if the performance issues go away.

December 29th, 2005, 01:18 PM
Yes, removing (or disabling) the Windows Conditional makes the performance problem go away.

But I need the conditional.....

December 29th, 2005, 07:47 PM
Try doing that with a window exists conditional.

December 30th, 2005, 10:56 AM
Try doing that with a window exists conditional.

Ron means the Window Exists action....

January 2nd, 2006, 01:30 PM
:roll: yes sorry.