PDA

View Full Version : Sanyo Z2 RS-232C connection - please help



nurowolf
February 6th, 2006, 04:35 AM
Hi All,

Hope somebody is able to help me with this little problem I am having.

I have a Sanyo Z2 projector that uses a DIN8 RS-232C connector for its communication (otherwise know as a Apple MAC Serial Port). However I am running Girder as my home control software. As such the RS-232 standards available to me are DB9 and DB25.

So hence the question

Does anybody know if it is possible to get a DIN8 -> DB9/DB25 adapter (or cable).

Sanyo was kind enough to make available all the RS232 codes available for the Z2, but that is kinda useless if I can't connect it to my Control unit.

Any help / advice greatly appreciated.

Regards
Nuro

Rob H
February 6th, 2006, 03:28 PM
Something like this I'd imagine http://www.connectworld.net/iec/l1528.html

nurowolf
February 9th, 2006, 01:16 AM
Yep - that would be exactly what I am after.

Only problem is that they are shipping from the states and shippings is US$22 and the cable is US$10.

Need to try and find this in Hong Kong

Rob H
February 9th, 2006, 03:42 AM
Surely there must be somewhere in Tsim Sha Tsui that sells them!

nurowolf
February 9th, 2006, 07:01 AM
You would think - but at the mere mention of a MAC interface cable - everybody starts shaking their heads.

May just be 'Lost in Translation'

Rob H
February 9th, 2006, 10:04 AM
Maybe print that advert and take it with you?

nurowolf
February 17th, 2006, 11:19 AM
Yep - that didn't work either.

The most common question I get asked is "Why would I want this'

Then the advice I get is - buy a new projector - yeah right!

Looks like I may just have to leave the Z2 off the automation list for now.

Rob H
February 17th, 2006, 12:45 PM
Should be possible to solder one up if you can find the specs for the connection. If you can find a suitable cable with at least one DIN 8 connector already soldered on then that would help. I'm going to have to do something similar for my Dell projector.

nurowolf
February 17th, 2006, 09:53 PM
SOldering is not really my strong point. Sanyo was kind enough to provide me with the pinouts - but I'm thinking that this is not a priority at the moment. Besides I still need to get NetRemote setup to replace my firefly. I think I may postphone this one for a little while.

I am in the USA in early May. WIll probably just get one sent to my office and pick it up then.

Thanks for the help and advice Rob.

Rob H
February 18th, 2006, 04:49 AM
That's probably the best idea

TheCowStir
April 27th, 2008, 02:53 AM
I made the connector with no soldering, just some crimping...

I took an Apple serial cable and cut the end off then crimped on an RJ45 connector.

I then took two RJ45 Jacks and created the appropriate pin out per the documentation, then off to an RJ45 to db9 adapter.

However all I get out of the cable is gobly-gook (Real Technical I know). I've tried both the 19200 and 9600 speeds specified in the settings, but nothing..

Anyone have any further luck with using this type of connector of a Sanyo projector? My version is a PLV-Z5.

If I can get this working via serial it would save me the cost of purchasing a Global Cache to be used just for IR control of this projector.

I have the Insteon working (mostly reliably) and my denon Receiver working, just need the projector and I can get everything started via an Insteon keypad...

So if anyone has had any luck using the RS232 on the Sanyo project Please post back.

Thanks

Rob H
April 27th, 2008, 03:15 AM
Can you post the gobbledegook? It might help determine the nature of the error.

Barf
April 27th, 2008, 06:15 AM
I have successfully controlled a Z4 over serial, through a the serial port of a GlobalCache, and am now successfully controlling a Z2000 the same way. Sensible documents on hardware and codes can be downloaded from http://www.sanyo.com.au, but to my knowledge not from other sanyo sites(!).

I bought an Apple connection cord, cut it it half, and soldered DB-9 connectors to the free ends.

The communication is then straightforward: you send a command like

C00\r

(that is four characters, three "normal" ascii characters and one carrage return character (0x0d)) to turt on (from standby). Note that there is no newline charcter (\n = 0x0a); this can be slightly tricky when experimenting using a terminal program like hyperterm or kermit.

Some commands return information on the serial (status, temperature, lamp time), not necessarily indispensable, so if you can send commands TO the Sanyo, that partial solution might be ok for you.

One more thing: you can set the rs232 speed in the service menu.

TheCowStir
April 27th, 2008, 02:56 PM
I have verified that my cable is correct by doing a continuity check on each pin from the minidin 8 male to the db9 female. (minidin pinout http://pinouts.ru/connector/8_pin_MINI-DIN_female_connector.shtml)

When I start the projector I still get junk on the terminal window (wĠuwġ - it shows up a little different with a terminal font, but similar).

The part about using the \r wasn't something that I was using, I was assuming that the Enter key would provide a CR (0x0d) however didn't verify just trying the CR. Using ctrl-m for the 0x0d I am now able to send message to the projector however they all respond with a "?" (and nothing happens on the projector) which per documentation means that the command was not parsed correctly. I have tried using minicom in Linux, SecureCRT and hyperterm in Windows all have the same result (using 19200,N,8,1 with no flowcontrol).

Could you post your lua scripts and a portion of a gml for how you control your projector? Maybe that will work while the terminal program won't. Or if there is a problem with how I am using the terminal progam, let me know.

Commands I have tried:
C00<crtl-m> (to turn projector on)
C01<ctrl-m> (to perform a quick-off)
C02<ctrl-m> (to turn off)
C1C<ctrl-m> (To bring up the menu)
CR3<ctrl-m> (To read the lamp bulb time)

All of these result in a "?" response.

I have not yet tried adjusting the speed of the port, but I guess that would be another step to try and change the speed down to 9600 and try again.

Any suggestions, or directions to follow up on?

Thanks
Todd


PS: For those looking for the service-manual, I have not found one for the Z5 online and free yet, but did find the Z4 at http://www.hometheatershack.com/forums/home-theater-projectors/98-sanyo-plv-z4-reviews-owners-service-manual.html

TheCowStir
April 29th, 2008, 11:26 AM
Something about using a terminal emulator seems to be my problem.

I used the Denon lua scripts as a starting point and am now able to send command to the projector.

I had to change one of the service mode settings from Super Standby to Normal standby so that I could issue a PowerOn command. (http://www.avsforum.com search from Sanyo Z5) This change is in the RS-232 command reference for the PLV-Z5.

Now to support all of the RS 232 commands I will need to work on the lua script. When I get that completed I will post my results, as they should work with most of the Sanyo Projectors as they all appear very similar as far as RS232 control is concerned.

If anyone else is working on this, here is how I made my cable:

Apple minidin 8 cable (I used a keyboard cable)


Cut the cable in half, and put an RJ45 end on the cable with pin 1 going to pin one etc.
Use two RJ45 jacks to perform the appropriate pin adjustments so that you can use a DB9 to RJ45 adapter on the computer end of the connection.



Thanks for the help Barf.

Todd

TheCowStir
May 26th, 2009, 01:56 AM
Finally I have figured out a simple solution to making an entire lua script for this...

My Sanyo Z5 projector is configured for an RS-232 port speed of 19200, so I modified the file SimpleSend.lua in Girder5\luascript\transport\devices to set the speed to 19200.

After that restart the lua scripting engine.

Then use the "Transport Actions" -> "Transport Send" to send the following to the device name created in the Transport Device Manager section with the "Simple Serial" device

HEX codes:

Power On
43 30 30 0d

Power Off
43 30 32 0d

Refer to the above mentioned Serial programming guide for additional directions. For Power on from standby I also had to modify the "super standby" option in the service menus of the projector.

ceejm1
December 30th, 2009, 06:24 PM
Would anyone happen to have a note of the Pin-out and serial codes for the Z2?

Thanks
James

TheCowStir
December 30th, 2009, 07:07 PM
Search on Google for "Z5 Basic Serial Command" and it should find a serial reference on one of Sanyo's international websites (.be I think). If you don't have any text past the title, you will somehow need to download the Japanese or Chinese font that it uses (my current corporate installed Acrobat reader isn't prompting to download the font...).

The port pinout and most of the commands should be the same. I only use the power on/off, and input switching commands. I also had to modify the power mode in the service menu as stated in a previous post to get the device to respond to power on commands across the serial port.

Hope this helps.

ceejm1
January 5th, 2010, 07:18 PM
Thanks for getting back to me. Got it sorted after a fair bit of fiddling! Here's a list of the commands I've had success with if anyone's wondering:

C00 power-on
C01 power-off (unconditional)
C02 power-off (Power Off ?)
C05 input = Input 2
C07 input = Input 1
C0D no-show
C0E return from no-show
C11 standard
C13 cinema
C14 image 1
C15 image 2
C16 image 3
C17 image 4
C18 game
C22 input 1 = auto
C23 input 1 = video
C24 input 1 = s-video
C25 input 1 = D4-video (component)
C1C menu on
C1D menu off

Cheers
James

DdC
February 28th, 2012, 11:16 AM
Dear James,
can you please explain how you could make the "C00" command working ? I can get all other commands work and can read all information, but I can't get the Projector opening the shutter and light up the lamp...?! am I missing something ? Thanks for your help and advise.
Dominic

TheCowStir
February 28th, 2012, 08:31 PM
You have to change the super standby option in the service menu otherwise you won't be able to wake the projector via Serial.

Directions that I used to access this menu I found at:
http://www.avsforum.com/avs-vb/archive/index.php/t-796587.html

Z5 Hidden Menus - what I know so far

Checking Lamp time: This menu shows how many hours the projector has been on and how many hours the lamp has been in "Normal" mode and how many hours in "Eco" mode.

How to Access it: Press and hold the POWER ON/STAND-BY button on the remote for more then 20 seconds. The screen will pop up briefly.

Service Adjustment Menu: This menu allows you to adjust the service data.

How to Access it: Press and hold the MENU button on the remote for 20 seconds. A "S" will appear on the screen. Now press and hold the "SCREEN" button on the remote for 3 seconds. You are now in the service mode. To exit press the POWER ON/STAND-BY.

WARNING: The OK, MENU, and pointer buttons all change service data values. Don't press them unless you know what you are doing or record the original values.

DdC
February 29th, 2012, 04:09 AM
Thanks a lot fior this valuable information: I'll try this and let you know the outcome. Appreciated.

DdC
March 1st, 2012, 11:32 AM
OK, here are the news: after AC was plugged on, I have Pressed and hold the POWER ON/STAND-BY button on the remote for more then 20 seconds which only opened the Shutter and powered the lamp on. Nothing happened on screen.
Doing the same a little later while lamp was ON just closed the shutter and switched OFF the lamp (so of course nothing on screen anymore)... Maybe I forgot to mention that I have a PLV-Z2000 and not Z5. Any other idea how to access this Service Menu on my Projector ? Thanks in advance. Dom