PDA

View Full Version : Girder and Virtual Dub not playing nice together



1856chuckles
May 4th, 2006, 01:15 PM
Hello All,
I'm using Girder 3.3. Win XP SP 2. On two different PC's. And an application called Virtual Dub (for capturing/editing video). On both PC's I have problems recognizing the application; however, the behavior differs as I'll explain below.

First PC: I can open the app from the desktop. I can Capture some mouse movements. I get to a part where I need to save a file and a child window pops up. The recognition of this window is flakey. I can Capture some of the actions and test them, they work fine. I apply the actions to an event and suddenly they don't work. I can't type anything in the text box where I need to put a file name. I try to use the Target feature in Girder but the Target window never comes up after pressing the button. Something seems wrong. I've tried stopping and restarting Girder. That no worky. ;-) I tried restarting the whole computer. That no worky either. So I moved on to PC numero 2.

Second PC: I can open the app from the desktop. I can use Capture but nothing seems to work on the app. From this PC I can use Target but as with Capture it doesn't seem to work. What I mean by doesn't work is that say I want to type some stuff in the Virtual Dub app, I use the Keyboard action and try and type some stuff in there and nothing happens. I can't even set the focus on the Virtual Dub app. Very strange. The things I can't do in Virtual Dub I can do in the Notepad application. Makes no sense to me.

So to sum it all up I've got 2 PCs with some functionality on both but not enough on either to do what I want to do. Does anybody have a stun gun or defibulator, maybe the computers need to be jump started? ;-)
No, seriously does anbody have any ideas?

Thanks
Ed ;-)

1856chuckles
May 5th, 2006, 12:35 PM
Well it seems that after a day I'm the resident expert on this topic. I've figured out a couple of things that may help others.
On my second PC I can do the things I want to do e.g. type into text boxes and navigate around using hot keys. It was my fault for not knowing how to use Girder I guess.

One issue is with the Target feature. I assumed that when you drag the little target over the object you want that action to occur, that it will automatically select that object. This is wrong, you have drag the little target over the object then you have to manually select the object from the list that appears in the target menus. Then click on apply I had to open the capture menu in order to help me figure out the objects.

Anyway still having problems with the other system not even being able to pull up the Target window with Girder. I do have the Tira plugin for IR on that one. Wonder if that could be causing problems?

Open for suggestions?
Ed