PDA

View Full Version : ATTN: MMcM! VFD only displays 2nd line...



ehrnam45
May 24th, 2006, 06:46 PM
Hey all, i'm still in the process of integrating hardware into my HTPC, and I've hit a snag: the LCD driver for girder lists my model (VK202-24 USB) but it doesn't correctly display output. The 'test' button on the LCD settings tab sends a string to the display, which only appears on the second line with "qrst...' and then scrolls the rest of the alphabet. attempts to send text to the second line result in no characters being displayed. The display is a VFD, built on the LK202-24 USB interface board, rev 1.6 iirc.

I've tried LCDC with the same result, and since the display list appears almost identical in both apps, I would assume a common framework in the .dll. I have successfully used the MO test app and uProject with this display, as well as LCD smartie (which worked great, but has very limited plugins for displaying the info I want.) What is the likelihood that the plugin has a small glitch that only affects this model? Any suggestions for further troubleshooting this? thanks in advance.

EDIT: After tinkering with it for a while, i realized that it wasn't displaying anything. I looked at the settings for the event under the LCD plugin, and by setting the row to 0, it displayed on the second row. you can't get to 0 from the spinner, and it won't take a -1 for an entry, so i'm stumped again. anyone else have this problem or this display?

Edit again: I've posted on the LCDC forums, but haven't come up with any solutions. This is really driving me crazy! Anyone have any ideas on what would cause this?