PDA

View Full Version : Seeing wrong "PLD1"



brianh4205
June 20th, 2006, 04:02 PM
Trying to get various status information from my AVM-20. When I send an event from Netremote to the AVM through serial port, I am getting feedback to netremote. Problem is that I am getting PLD1 from netremote rather than from the AVM.

The code is:
local a =(pld1)
print (a)
NetRemote.SendLabel ("station",a)


What I am getting back to netremote is the PLD1 from netremote. Need to figure out how to get the AVM PLD1.

This is what I am seeing. Question is how do I get AVM PLD1 instead of NR pld1.

This is a station change...
EVENT: Dev: 203 nr.104.7 Pld1: 192.168.0.105 Pld2: nr.104.7
LUA: call main
LUA: --> call C print global
LUA: --> --> call C tostring global
LUA: --> --> return C tostring global
LUA: --> return C print global
LUA: --> call Lua SendLabel field
LUA: --> --> call Lua PackLabel field
LUA: --> --> --> call C strlen global
LUA: --> --> --> return C strlen global
LUA: --> --> --> call C strlen global
LUA: --> --> --> return C strlen global
LUA: --> --> return Lua PackLabel field
LUA: --> --> call Lua Send field
LUA: --> --> --> call C send field
LUA: --> --> --> return C send field
LUA: --> --> return Lua Send field
LUA: --> return Lua SendLabel field
LUA: return main
EVENT: Dev: 140 avm:
Pld1:
Pld2: Data Pld3: avm Pld4: COM1 Bin: 0A
EVENT: Dev: 140 avm: TFT104.7
Pld1: TFT104.7
Pld2: Data Pld3: avm Pld4: COM1 Bin: 54
46 54 31 30 34 2E 37 ...

Promixis
June 20th, 2006, 08:55 PM
ok, what do you want to send to NR?

brianh4205
June 20th, 2006, 09:55 PM
Need to get PLD1 from AVM instead of PLD1 from NR. Can get the info from pld1 or dev: 140 avm: TFT104.7. The 104.7 is the station..

EVENT: Dev: 140 avm:
Pld1:
Pld2: Data Pld3: avm Pld4: COM1 Bin: 0A
EVENT: Dev: 140 avm: TFT104.7
Pld1: TFT104.7
Pld2: Data Pld3: avm Pld4: COM1 Bin: 54
46 54 31 30 34 2E 37 ...

Thanks for the response...

Promixis
June 21st, 2006, 03:28 AM
ok, cannot you not just use sendlabel using pld4?

brianh4205
June 21st, 2006, 08:12 AM
If I change to PLD4 all I see on the NR button is "com1" for any status change.

Is there some way to eliminate the NR info so the only pld1 seen on the serial event is from the avm..

If you can get me through this maybe you can help me understand why my powerlinc is blowing my USB ports.....

Rob H
June 21st, 2006, 10:01 AM
Where are you putting the NetRemote.SendLabel?

brianh4205
June 21st, 2006, 11:14 AM
Variable manipulation script in girder. The command is on generic serial.....

local a =(pld1)
print (a)
NetRemote.SendLabel ("station",a)

Rob H
June 21st, 2006, 12:30 PM
What event are you using to trigger it?

brianh4205
June 21st, 2006, 12:40 PM
Serial also..

Also have invert checked in serial port

brianh4205
June 22nd, 2006, 06:22 AM
Nothing a quick re-boot won't fix....