PDA

View Full Version : Inconsistent codes



Strahan
July 13th, 2006, 01:53 PM
Hi. I'm trying to teach Girder how to control my Sanyo Z4 projector. I have a macro setup and I added USB-UIRT function to it. Chose transmit IR in the dropdown and clicked the learn IR button. I hold down the PC input selector button on the remote and the bar goes across on the Girder learning window and it gives me a code. Test transmit does nothing though, and sometimes the codes change even though it's the same button.

My cable TV remote is even worse, it gives bunches of wrong codes. Is this an issue with the remote or do I need to do something differently? Thanks!

Rob H
July 13th, 2006, 02:32 PM
Make sure you are using new batteries in the remote that you're trying to learn from.

Also try to make sure that there are no other infrared sources that could confuse things.

danward79
July 13th, 2006, 04:06 PM
One other thing. Some remotes transmit two different codes for a given command alternately. I had this before with the StreamZap Remotes and the UIRT.

So you press the button once you get code 1, next press Code 2, next press code 1, etc.

toml0006
July 14th, 2006, 12:13 AM
I have seen the exact problem you describe. I have found that I just have to keep re-entering the code until it seems like the 'appropriate length' (which is suprisingly long).

Strahan
July 17th, 2006, 04:14 PM
Thanks, it worked. I held it closer and kept training until I got a real long code, and when it hit test transmit worked perfectly.

Thanks again!