View Full Version : Unable to open COMport

September 22nd, 2006, 09:55 AM
Hello there,

I am using Girder for a few months now and everything worked fine. A few weeks ago I extended the cable between the IR receiver and the 'device' that goes in my COMport. In the beginning it all worked fine, but now Girder gives a message "Unable to open COMport" when I boot it. I switched the port, still the same problem. I checked the soldering and cables, and everything seems fine. What could be the problem? Girder doesn't react at all to my remote.
Thanks in advance!

Rob H
September 22nd, 2006, 03:05 PM
Most likely something else is using the COM port - have you installed any new software lately?

September 22nd, 2006, 04:17 PM
I later realised the COMport could be in use. So I checked the internet and found this page: http://www.promixis.com/forums/archive/index.php/t-6387.html . I installed Serialwatcher and found out the port is in use. I uninstalled the port. Now Girder doesn't give an error anymore, but it isn't still working. My Igorplug doesn't give any errors, which did before the uninstall.
So if I'm right, the port isn't in use anymore, because I can open it with serialwatcher. But I still don't receive any signals (neither with serialwatcher). Where is the problem? I think between the remote and the port (so, actually the hardware) but I'm not sure.

EDIT: I found out that serialwatcher gives a signal when I open the port. But when I have the receiver disconnected from my port serialwatcher doesn't give any signal anymore. Maybe this could help you.