PDA

View Full Version : Multigroup + USB-UIRT Problem



white_2kgt
March 14th, 2007, 06:20 PM
I'm trying to create a macro that will change the source of my TV (using IR Blast), so it goes something like this,

Menu
Left
Left
Up
Select

I have an EventString that corresponds to a button on my remote. When I execute the macro with F5 it works. When I run the macro w/ the remote button that's associated with the remote button the macro runs several times, this of course changes the source again. I've deleted it and started over several times, even tried different commands and I still get the same result. What am I doing wrong?

I have covered the blaster on the UIRT and I'm using an Emitter directly on the TV but I still get the same results.

Thanks,
Chad

Treetop
March 23rd, 2007, 01:10 PM
I have no idea why it would run several times when using the remote, other than the remote is sending the signal several times. test with another remote just to rule it out as a possible source of IR pollution.

One way to hack around this problem (just off the top of my head).

At the end of your macro, make a command that disables the group.

Make another macro. This one will have 2 commands: Enable the group and a Goto command. Tie the remote button to this macro.

There are 2 options in the usb-uirt config... repeat and wait. you can try messing with those to see if it helps as well. I have never played around with those settings, so I don't know if they will work, but its worth a shot.