PDA

View Full Version : Compact Flash to IDE adapter for Solid State NetRemote Stations



NeoMorph
August 10th, 2007, 12:15 AM
Well I got my 4GB 133x Compact flash card and CF to IDE adapter...

Started to install windoze onto it on my test PC and thought "this is slow..." I checked the adapters paper and noticed some tiny print...

"Accord with: CF Spec Ver2.0 and IDE/ATA-33 spec"

DOH!

I have a version 4 card that can handle UDMA-133 and an adapter that can only run at UDMA-33. That missing "1" is causing 1 hell of a bottleneck.

Now it looks like I'm going to have to search for someone who sells v4 spec adapters. :( Does anyone know of anyone who sells these?

Luckily my current adapter only cost 4 (off eBay brand new) so it's no great loss. I only bought it to do testing with anyway as the 4GB card was originally destined for my digital camera for use at our family barbecue in September.

NeoMorph
August 14th, 2007, 10:41 AM
Well... another card adapter and another failure.

I'm beginning to think that I'm going to have to go with a hard drive after all. I just haven't got a clue why it installs windows fine but then refuses to boot.

Rob H
August 14th, 2007, 12:57 PM
What error do you get on boot?

NeoMorph
August 14th, 2007, 01:46 PM
None... it just hangs there waiting for something.

I think I finally have got to the bottom of the problem though. It turns out that Windoze sees my CF as a removable device even though it's plugged into the ide socket.


Note: It has been discussed on various news groups that SanDisk no longer makes industrial grade CF cards, nor do they supply a utility that makes the drive ID'd as fixed in Windows.

When I found that it made me check and yup, it's showing up as removable. I've emailed Sandisk (my card is the Sandisk Extreme III 4gb model) and I hope that this card is modifiable. I've also spotted comments that models that end in 388 are compatible with the utility where others are not. If not I hope I can get it working correctly in my camera as it keeps messing up and only accessing 2gb instead of 4.

I'm actually starting to regret getting the Sandisk CF card now but I've bought Sandisk before and previously found them ok.

Edit: Camera is an old Canon Powershot A20 that uses FAT16 which can only see 2gb max apparently. What a pita... can't use it to boot windows and can't use it fully in the camera. What a waste of 50!

NeoMorph
August 16th, 2007, 11:41 AM
Well I finally got the information I required from Sandisk...



Thanks for email SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

Per SanDisk business guidelines, the tool being requested is available only for customers who utilize SanDisk OEM Compact Flash product, SDCFJ-xxx-388 or SDCFH-xxx-388.

If you are not buying the products mentioned above, please contact a SanDisk OEM Representative or SanDisk OEM Distributor for your region. The distributors are listed on SanDisk Web site

http://www.sandisk.com/Oem/WhereToBuy.aspx (http://www.sandisk.com/Oem/WhereToBuy.aspx)

If you utilize the OEM products mentioned above, a purchase confirmation is required from you or your SanDisk Sales Representative before a Software License Agreement (SLA) is emailed to you for signing and returning back to SanDisk's Legal Department for approval. After the SLA has been approved, the utility will be provided to you as requested.

Best regards,
Rafael B.
SanDisk Technical Support


My advice is that anyone thinking of using compact flash as a boot device had better stay away from Sandisk because..

1. You can't boot from them... unless...
2. ... you buy OEM stock from a limited number of suppliers (ie no going to your normal supplier who has the best prices)
3. You have to sign a software licence just for a silly utility to make them bootable which seems to be way over the top here.

I have wasted 50 on a card that just won't do what I want it to do.

Talk about being depressed!

NeoMorph
September 19th, 2007, 05:27 PM
Well after doing a lot of painful failures and the email from Sandisk themselves that seemed to indicate that you can't boot XP from my Extreme III CF card I was rather confused when I read that people actually had managed to install XP pro onto them fine.

It took a bit more research but ironically I found the answer here of all places.

http://www.promixis.com/forums/showthread.php?t=16937&highlight=ITX

In Marcel's first post he mentioned EWF which stands for Enhanced Write Filter. Now not nowing what this actually was I though it may be something that I should know about and how right I was. Basically there was a tutorial on how to make compact flash read only using parts of the XPe (XP Embedded) operating system trial.

It was only when I was reading through the tutorial that I came across..


Off-the-shelf CF cards come configured as removable drives and can only be formatted as FAT. Windows XP will not allow you to partition and format a removable drive with NTFS, so you must use FAT. You can sometimes get a special utility from the manufacturer to configure the drive to be fixed. XPe includes a special tool called Bootprep.exe that is used to make FAT formatted disks able to boot into Windows XP. To setup a CF disk using FAT you’ll need a DOS boot disk with fdisk.exe, format.com, and bootprep.exe.

... which was the final piece of information I needed to get my CF card working as I wanted. I tried following the information but it left out one piece of information and that was that Bootprep needs to be run from the drive you want to boot from as it needs to write to the disk. The instructions in the tutorial say...


Once you’ve confirmed that your CF card boots successfully, reformat the card by just using “format c:” (no /s switch) and then finally run Bootprep. The command for Bootprep is “bootprep /dc” (the /d switch specifies which drive to use).

... which imply you can run the bootprep command from anywhere. This is not true.

Eventually the way I did it was to install a ghost copy of my operating system onto a D: drive and copied the files from there to the flash drive. I then tried to boot the flash and it failed because I had tried to Bootprep from the CD drive. I then booted into dos and switched to the CF card and ran "bootprep /dc" again... I then tried to boot from the CF card and was amazed when it all worked fine and windows booted.

Well time for bed said Zebedee. At least this is another project successfully completed. I now need to get my car and then my ITX hardware so I can have a totally solid state terminal.

Rob H
September 20th, 2007, 03:06 AM
Congratulations - looks like persistence pays off :)

NeoMorph
September 20th, 2007, 05:05 AM
Congratulations - looks like persistence pays off :)

Yeah... I hate things to beat me. Taking the break and working on the SMS problems was the answer - sometimes concentrating on a single problem means you sometimes miss the answer that is right in front of you, just like this time. If it hadn't been for Marcel's link to the EWF tutorial I would still have a 50 piece of plastic on my hands because I hadn't found the info about bootprep.exe being a fix for unbootable CF cards anywhere else on the net.