PDA

View Full Version : Problem with NetRemote: multiple functions assigned to one button



lausteve
December 10th, 2007, 04:09 PM
I just purchased Net Remote for a home theater project. I connected it with the UBS-IRT transmitter. I am unable to successfully get a single button to issue multiple IR commands.

For my simple application, my "TV POWER" button works just fine (able to toggle TV on and off) as a simple single function.

The problem occurs when I attempt to add more than one function to the button. When I attempt to add additional commands to this "TV Power" button, I am unable to get the TV to respond. In other words, single commands work great but when I attempt to add to the single command (even something as easy as: "beep" or "delay 100ms"), the original function stops working. What I really want to do is to have the "TV Power Button" turn on the TV and then turn to channel 13.

My simple example:
1) Turn on the TV (send the power on code to the TV)
2) Select channel 13 (send the "1" key, send the "3" key)
3) Send the "enter" code

Can you provide any advice or assistance? Is there a setting that tells NetRemote that multiple commands are bring used? Is this something to do with the need to "repeat the code"?

Any assistance would be greatly appreciated.

tmorten
December 10th, 2007, 07:41 PM
I think NetRemote might only be repeating the IR code if it's the only action associated with the button, so adding additional actions may make the IR burst too short. I have it on my list to look at the USB-UIRT code this week, so I'll try to rectify that for the next build.

Best,
Tim

maxthebuilder
December 11th, 2007, 06:18 PM
Worked for me when I last used the IR function of my PPC.
Not very reliably as far as I can remember - sometimes would drop a command or two but this is the case with my harmony remote too when it's doing macros (mostly with my TV - not a very good IR sensor I guess).

Did you try to adjust delays between commands? Some devices need large delays (my TV needs 7-8 sec).

--max



I just purchased Net Remote for a home theater project. I connected it with the UBS-IRT transmitter. I am unable to successfully get a single button to issue multiple IR commands.

For my simple application, my "TV POWER" button works just fine (able to toggle TV on and off) as a simple single function.

The problem occurs when I attempt to add more than one function to the button. When I attempt to add additional commands to this "TV Power" button, I am unable to get the TV to respond. In other words, single commands work great but when I attempt to add to the single command (even something as easy as: "beep" or "delay 100ms"), the original function stops working. What I really want to do is to have the "TV Power Button" turn on the TV and then turn to channel 13.

My simple example:
1) Turn on the TV (send the power on code to the TV)
2) Select channel 13 (send the "1" key, send the "3" key)
3) Send the "enter" code

Can you provide any advice or assistance? Is there a setting that tells NetRemote that multiple commands are bring used? Is this something to do with the need to "repeat the code"?

Any assistance would be greatly appreciated.