PDA

View Full Version : Girder 4, NR2 and GC100 Interesting prob ?



zones
December 28th, 2007, 03:57 AM
Hi All,

I recently upgraded from Girder 3 and NR1 and I am have problems with my system.

When I click on a NR button which runs a lua function that then calls a Girder action which in turn sends IR to the GC-100 it only works about 50% of the time. This worked reliably on the previous versions.

When I use F5 in Girder to test the action it work 100% of the time.
When I watch the Log Display in Girder it receives the NR/Lua event and issues the GC-100 command 100% of the time.

This does not seem logical to me, but that's what I have observed.

Does anybody have any clues as what to try next.

Zones

Ron
December 28th, 2007, 01:58 PM
Can you upload your CCF and GML and tell me exactly what to do to reproduce the problem.

zones
December 28th, 2007, 03:34 PM
Ron,

Please find attached a zip containing my cut down files. I have tried to eliminate all none essential components as part of my atempt to fix the problem.

Once you start NR and click on the start button you will see the main screen, the problem can be seen when you select Radio then Server several times.

Radio should issue a call to the Gider event "MT"
Server should issue a call to the Girder event "MAV1"
This seems to work fine.

Both the MT and MAV1 should issue IR to the GC via "GC IR" actions.
As I said in my orignal post the Girder log display shows this happening.
But the GC only issues the command to the IR emmiter less than 50% of the time.
MT also issues a event Rpower which originally set a NR varible to show the Radio is on.
As I have not got this working on the new versions it currrent calls a on screen message (as a place holder)

Versions NR 2.0.0.99
Girder 4.0.14

I hope this info helps.

It is is a long time since I set my system up so it is very possible I have made a simple mistake.

Cheers
Geoff

Ron
December 28th, 2007, 03:46 PM
I have not been able to find the events MT nor MAV1, one thought however, do you have multiple computers/applications talking to the GC?

zones
December 28th, 2007, 03:56 PM
Ron

In Girder look under
Amplifiers - Marantz Kitchen - Tuner
Amplifiers - Marantz Kitchen - AV1

As for multiplke system it is possible but I dont think so I will 100% check my dev box is not on try again and will let you know.

Geoff

zones
December 28th, 2007, 04:18 PM
Ron,

Just tried with the only the media server (Girder) and a single NR client (no Girder) so only one link to the GC.

Same problem no difference.

Attached is a jpg showing the log display.

You will see two entries at 22:11:03 these came from the first press on the server button, this did not fire the IR emitter.
I then pressed the server button again 22:11:40 and it worked this time.

Lets hope you can reproduce this and save my sanity.

Geoff

zones
January 5th, 2008, 03:16 AM
Following advice from Ron I have given G5 a try.

G5 has vastly improved the problem. About 1 in 10 - 1 to 1 in 20 times I still see Girder send the GC command and nothing happens. Also when the command is missed the next click tends to work ok with G4 it seemed to be much worse following the intial fail.

In short the system is useable again.