PDA

View Full Version : USB-UIRT driver problem



cbouder
January 27th, 2008, 02:07 PM
Hello,
I'm having difficulty getting Girder to recognize any IR signal from any remote.

OS = MCE 2005
IR Transceiver = SMK AXX0000-3853F
IR Remote = Phillips Pronto TSU3000
Girder ver = 4.0.15 (build 371)

The transceiver is recognized in device manager as a Microsoft eHome infrared transceiver under Human Interface Devices with no apparent problems.

I have enabled the HID plug-in in Girder with no apparent problems.

When I try to enable the USB-UIRT plug-in, the plug-in is highlighted red and the log produces the following message "UIR Failed to initialize. Error: Unable to find USB-UIRT Driver. Please make sure the driver is installed!"

I have usbuirt.dll in the Girder\plugins directory.
I have usbuirt.xml in the Girder\plugins\UI directory.

I have tried two different versions of those files in addition to the files that come included with the Girder 4 install and have had no success. (I renamed previous files with a .old extension)

To this point Girder does not log any IR events received by the transceiver.

Any advice is appreciated.

Thank you

PEACE / LOVE

Rob H
January 27th, 2008, 05:01 PM
Um... the USB-UIRT plugin is for the USB-UIRT hardware only, it won't work if you don't have one.

It does sound as though you should be able to use this device via the HID plugin though.

cbouder
January 27th, 2008, 11:15 PM
Thank you for that info about USB-UIRT. My mistake.

So,
With that setup, and the USB-UIRT plug-in disabled, what are my troubleshooting steps to figure out why Girder doesn't register an event when the IR sensor is hit with a signal?

The LED on the IR sensor is lighting up when hit with an IR signal. I happen to have 9 identical receivers, have tried all 9 and get a negative response every time. What else should I be looking at?

Thank you

PEACE / LOVE

cbouder
January 27th, 2008, 11:20 PM
Forget it for now, it looks like I am now getting a recognition response from Girder after a few reboots and other non-sense.

Thank you for your prompt reply.

PEACE / LOVE