View Full Version : Can't run NRD

June 21st, 2008, 08:18 AM
I just upgraded to the latest versions of NR (126) and designer (51). Now I can't start designer. NR runs with no problems but designer will not run. I get an error message while the splash screen is showing and then it will freeze and I have to kill the process.

This is from the log file:

Creating CoNetRemoteHelper
Creating CoNetRemote
Getting Namespace
Getting plugins
Connecting to NetRemote object
There was an uncaught exception initializing the application
Det angivna argumentet hamnade utanför intervallet med giltiga värden.
Parameternamn: index vid System.Windows.Forms.TreeNodeCollection.get_Item(I nt32 index)
vid com.promixis.Forms.LuaReferenceInformationForm.Ref reshVariables()
vid com.promixis.Forms.LuaReferenceInformationForm..ct or(NRIEditorForm parent)
vid com.promixis.Forms.NRIEditorForm..ctor(String filename)
vid com.promixis.Forms.NRIEditorForm.Main(String[] argv)

"Det angivna argumentet hamnade utanför intervallet med giltiga värden." translates into "The argument is out of bounds"

Rob H
June 22nd, 2008, 04:37 AM
Hmm... that's very strange - can you try loading another CCF into NetRemote, then closing and restarting it. Then try NRD again.

June 22nd, 2008, 08:58 AM
I have tried five different ccf files including "Flatstyle Music and DM.ccf" and "mce_480x640.ccf".
I also tried different versions of designer (44, 45, 48, 51) and different versions of NR (124, 126). None of the combinations work. Same error and behavior.

When I think of it I'm not sure I have ever used designer on this computer before so I'm not sure if it has worked with previous versions.

I have Windows XP.

Any ideas?

Rob H
June 22nd, 2008, 12:51 PM
Are you running Girder? It's possible that it's sending something that's confusing NRD.

Alternatively something may be interfering with COM access to NetRemote.

Another possibility given that you are using a non-English version of Windows is that there is something strange about the path to the temporary folder, e.g. non-ASCII characters.

June 23rd, 2008, 06:26 AM
I'm not running girder.

I tried to install NR and designer on my other computer and I get the same error. That computer is also running Swedish Windows XP.

I have been using NR and the designer version that worked with that NR version, before I upgraded to the latest versions of both, and back then there were no problem running designer.

Rob H
June 23rd, 2008, 07:40 AM
Can you open a command window and type

set tmp


set temp

and see what it's reporting as the environment variables for these - I strongly suspect that at least one of them will be using non-ASCII characters

June 23rd, 2008, 08:05 AM
C:\>set tmp

C:\>set temp

The full path is:

C:\Documents and Settings\Peter Gustafsson\Lokala inställningar\Temp

So you are right, there is an swedish character in the path.

Rob H
June 23rd, 2008, 10:14 AM
The solution is to create a C:\temp folder and use Control Panel\System to set the tmp and temp environment variables to use that folder.

The underlying cause of the problem is that NRD sends some Lua code to NR using one of those paths - but Lua can't cope with non-ASCII characters in filenames.

June 23rd, 2008, 12:41 PM
That did the trick.
Thanks :)