PDA

View Full Version : Cannot add actions to my buttons



kimagure
February 21st, 2009, 09:48 AM
Hi

I've just upgraded my Netremote Designer to build 9 (2.0.0.9) and I've got an issue I did not have with the previous version.
I am using Windows Vista 32bits US and I am running NR Designer as administrator.

I want to add an action to a button, but my changes are not saved when I click on the OK button.

Here is what I'm doing :
- On the Action Designer tab, I'm double-clicking on the desired action (in my case a NRBasic / Variable Manipulation / Set variable to value)
- I'm fillling the parameters for the action (variable name, value) and click on OK
- the action is visible in the list of actions associated to my button, on the right of the action designer window.

I click on OK to validate my change.
When I click on my button, the specified action is not executed. If I go back to the action designer, my "set variable" action is not visible anymore...

As a test, I tried to add my action twice. My button is working. If I go back to the action designer, I see the action only once. If I validate the action designer window again, my button is not working anymore, as above...

FYI, I tried with other types of action (lua script, send event to girder) and I've got the same issue, so it's not related to a specific plugin...

Do you know what could be the problem ?

Thanks

K.

Rob H
February 21st, 2009, 11:33 AM
This is a known bug in 2.0.0.9 - the element properties window is being phased out in favour of the properties pane which should appear by default under the tree pane. Use that to change the actions (and preferably all other properties) instead.

kimagure
February 21st, 2009, 12:53 PM
Thanks...
It's working when modifying the action list using the property pane...

K.