PDA

View Full Version : Copy from one CCF to another bug



jwilson56
May 14th, 2009, 05:37 PM
There are some major issues when you copy stuff from one CCF to another. I was showing a new guy some things today and copied the "Cover Image Frame" and all the child items from the Flat to his CCF and it was all screwed up. You could not click on it... other weird stuff...

jumbodogs
May 14th, 2009, 06:17 PM
Sorry about the other post I made its the same error as jwilson56 is talking about here ... got busy in middle of post ... anyway


I did some more testing and it seems that if there is anything is side the frame it screws it up when you copy it. I tried a frame with just a button in it and I also tried a frame with just another frame in it. I paste them into another ccf and they become unusable.

I did some more testing and I found that I can copy the stuff individually and it works fine.

Rob H
May 14th, 2009, 07:00 PM
Right, sounds like it's not setting the owner property correctly. I'll fix it tomorrow.

Rob H
May 15th, 2009, 07:58 AM
I've not been able to reproduce this here so far - copying frames with other elements in them between CCFs seems to work okay for me. I can select the elements in the pasted frame without problems, from both the tree and the right hand pane.

Can you walk me through a simple example that shows the problem?

jumbodogs
May 15th, 2009, 11:08 AM
I can't reproduce the error anymore. When i was testing it yesterday I simply made a frame with a button inside it. I would copy the frame with the button in it then once I pasted it into another ccf file it would become unusable. I am pretty sure yesterday that I got an error message at some point and kept using NRD. I am thinking that is what was causing the problem.

I will try to keep track of the error message that pops up.... I have gotten it a few times. Something about unusable variable.