PDA

View Full Version : system.threading.threadexceptioneventargs



AlanB11
November 6th, 2009, 03:20 AM
Hi guys,

I am having some problems with Netremote Designer. I was part with through creating a new ccf file, using Designer 2.0.0.14, and started getting a problem when I try to add any action (inlcuding delays) to a button. When I click 'Ok' it just hangs, and if I click 'Cancel' I get the error:

system.threading.threadexceptioneventargs.

I have tried updating to version 2.0.0.16, no improvement, so went back to 2.0.0.14. This occurs even if I create a new ccf file with one button. I am using XP Pro SP3. Any suggestions?

Thanks,

Alan

Rob H
November 6th, 2009, 08:03 AM
I can't reproduce this here :(

What CCF format revision are you using? 1.1 rev 1.4 or 1.5?

Can you take me through the steps to reproduce this reliably?

AlanB11
November 7th, 2009, 11:41 AM
Hi Rob,

I am using revision 1.4, but just tried 1.5 and get the same problem.

It happens on all files now. So even if I create a new file, and add a button to the Home page, I look at the properties for the button. Click on the action list, add an action (for example 'Delay') by double clicking on it and selecting the default 100mS, then click OK to exit the 'Specify Delay Time' screen - the Delay gets added as an action type, but when I click OK to exit, nothing happens, the Action List window just stays open. If I click Cancel, I get the system threading error message.

Alan

Rob H
November 7th, 2009, 05:22 PM
I wonder if this is related in some way to the plugin configuration in NetRemote?

First, what version of NetRemote are you running?

Second, what plugin instances do you have there? Maybe you could disable autodiscovery there and delete plugin instances one at a time. I'd suggest first of all using RegEdit to export the key
HKEY_CURRENT_USER\Software\Promixis\NetRemote to a file as a backup.

janikw
December 20th, 2011, 06:35 PM
Rob,

I know this thread is very old, however, I have exactly the same problem. I haven't edited my ccf for quite some time, but now find it impossible to do so due to the issue above. I also tried going back to V1 of the designer, but got a whole host of other errors. I get this, for example, when trying to copy and paste an element:

6348

I hope you can help,

Regards,

Janikw