PDA

View Full Version : Corrupt CCF preventing netremote start?



tdemelle
April 18th, 2010, 11:40 AM
I'm unable to start NetRemote I suspect because of something wrong with the my first clumsy attempts with netremote designer. Here's the data I get from Debugview.

[3012] 11:35:52.708] ScriptEngine] INIT: Loading hotkeys
[3012] 11:35:52.709] ScriptEngine] Couldn't load pronto font resource
[3012] 11:35:52.709] ScriptEngine] INIT: Loading drivers
[3012] 11:35:52.709] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_avidutils.dll
[3012] 11:35:52.724] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_flash.dll
[3012] 11:35:52.741] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_generic.dll
[3012] 11:35:52.756] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_girder.dll
[3012] 11:35:52.769] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_ir.dll
[3012] 11:35:52.782] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_mediabridge.d ll
[3012] 11:35:52.794] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_nrbasic.dll
[3012] 11:35:52.807] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_webbrowser.dl l
[3012] 11:35:52.819] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_webserver.dll
[3012] 11:35:52.831] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_wol.dll
[3012] 11:35:52.843] ScriptEngine] C:\Program Files (x86)\Promixis\NetRemote\plugins\drv_zoom.dll
[3012] 11:35:52.856] ScriptEngine] INIT: Getting skin filename
[3012] 11:35:52.877] ScriptEngine] INIT: Attempting to load ccf
[3012] 11:35:52.900] ScriptEngine] Creating CCF object
[5832] DllMain
[5832] DllMain
[5832] DllMain

Somewhere around the creating CCF object, I get an error dialog... Netremote has stopped working with the only option to close the program.

Rob H
April 18th, 2010, 05:57 PM
Rename the CCF file and restart NetRemote - it will prompt you to load another one.

Rob H
April 18th, 2010, 07:35 PM
And if you can send me the CCF I'll try to improve NetRemote's performance with bad CCFs.

tdemelle
April 19th, 2010, 12:24 AM
Thanks, Rob. I appreciate the help. Changing the ccf filename worked.

I'm pretty sure the problem arose when I tried to open a ccf directly from within NetRemote instead of exporting it over from the designer. I've attached the file in case it's helpful. Not much more than blank buttons at this point.

I've since run into a second issue attempting to recreate the file anew. I'm not sure it's related, but it may be. I'll describe it here and move it to another thread if you prefer.

Basically, I began by creating a series of buttons in the masterTemplate. Once those were in place, however, I was unable to add buttons to the home->home page. Instead of allowing me to add a button, right clicking resulted in the following error:

System.Threading.ThreadExceptionEventArgs

Any insight you can provide is much appreciated!

tdemelle
April 19th, 2010, 10:26 AM
Restarting seems to have corrected whatever was causing the issue.

Rob H
April 19th, 2010, 11:38 AM
That CCF is very odd, for some reason your TV device's next pointer is pointing to itself! I'm attempting to handle this situation in the next build.

Did you have just one extra device or were there more?

tdemelle
April 19th, 2010, 11:59 AM
Thanks, Rob. I will have more than one device. I am trying to iron out the format and function of the initial home pagegroup and then will use that to copy and paste out other pagegroups for other devices.

If I recall I created the 2nd pagegroup in the ccf above by copying and pasting the home pagegroup to start getting a feel for how they'd string together and how the production pipeline will work. Perhaps the strangeness with the TV device's self-referring pointer is an artifact of copying and pasting?

Rob H
April 19th, 2010, 04:40 PM
That's possible, I'll try to reproduce it here.