PDA

View Full Version : Windows 7 zoom player losing setup



jolly1
April 18th, 2010, 10:37 PM
Hi,
Have just moved HTPC onto new pc with windows 7 64 bit. I previously on the xp machine used the following. To start zoom and load a movie

avar = pld3
print(avar)

local file = io.open(avar, "rb") --checking if file is on hard drive
if file then file:close()
flag = [["/config:c:\program files (x86)\zoom player\setup.local"]]
--..[["]]..[["/config:c:\program files (x86)\zoom player\setup.local "]]
avar = [[/f ]]..[["]]..avar..[["]]
print("found ".. avar)
win.ShellExecuteEx("zplayer.exe", avar ,[[C:\Program Files (x86)\Zoom Player]] ,win.SW_SHOWNORMAL)
Denon:VCR1 ()
NetRemote.Jump("DVD Player", "DVD Playing")
-- is called from play button gir.TriggerEvent("MoveMouseMacro", 18) -- just added trying to call movemousemacro
else
NetRemote.Jump("DVD Player", "DVD Not Found") -- jump to page on Netremote that warns no Hard Drive
print("not found "..avar)
end

Now everytime I call zoomplayer it ask be to enter the basic setup again eg audio and video settings.

Even tried file action and again it ask to setup again.

If I open zoom and setup (which I can shut down and open no problem)
then call it via netremote / girder ask for the setup.

Even if run the action directly from girder.

Not shure if this is girder problem a zoom problem or windows 7.

Search thro zoom forums and the only thing I could describing a similar problem was people with non registered versions. It is a fully register version of zoom mzx.

Have set to smart play.

Basically netremote sends the location of the folder to start in. The script checks it exists and then plays.

really struggling to find soloution

jolly1
April 18th, 2010, 10:39 PM
Hi,
Have just moved HTPC onto new pc with windows 7 64 bit. I previously on the xp machine used the following. To start zoom and load a movie

avar = pld3
print(avar)

local file = io.open(avar, "rb") --checking if file is on hard drive
if file then file:close()
flag = [["/config:c:\program files (x86)\zoom player\setup.local"]]
--..[["]]..[["/config:c:\program files (x86)\zoom player\setup.local "]]
avar = [[/f ]]..[["]]..avar..[["]]
print("found ".. avar)
win.ShellExecuteEx("zplayer.exe", avar ,[[C:\Program Files (x86)\Zoom Player]] ,win.SW_SHOWNORMAL)
Denon:VCR1 ()
NetRemote.Jump("DVD Player", "DVD Playing")
-- is called from play button gir.TriggerEvent("MoveMouseMacro", 18) -- just added trying to call movemousemacro
else
NetRemote.Jump("DVD Player", "DVD Not Found") -- jump to page on Netremote that warns no Hard Drive
print("not found "..avar)
end

Now everytime I call zoomplayer it ask be to enter the basic setup again eg audio and video settings.

Even tried file action and again it ask to setup again.

If I open zoom and setup (which I can shut down and open no problem)
then call it via netremote / girder ask for the setup.

Even if run the action directly from girder.

Not shure if this is girder problem a zoom problem or windows 7.

Search thro zoom forums and the only thing I could describing a similar problem was people with non registered versions. It is a fully register version of zoom mzx.

Have set to smart play.

Basically netremote sends the location of the folder to start in. The script checks it exists and then plays.

really struggling to find soloution

the line with flag was me attempting to start with a local config file whicj didn't work either. This was not in the orginal working version

apologies for two post

blubberhoofd
April 19th, 2010, 04:58 AM
Seems like the working directory is wrong (missing a trailing slash).

try this:

local avar = pld3
print(avar)

if win.FileExists(avar)then

print("found: "..avar)
avar = "/f \""..avar.."\""
win.ShellExecuteEx("C:\\Program Files (x86)\\Zoom Player\\zplayer.exe", avar, "C:\\Program Files (x86)\\Zoom Player\\", win.SW_SHOWNORMAL)

Denon:VCR1 ()
NetRemote.Jump("DVD Player", "DVD Playing")

else

print("not found: "..avar)
NetRemote.Jump("DVD Player", "DVD Not Found")

end

--changed: working directory, file exists check, path notation, made 'avar' local

jolly1
April 19th, 2010, 06:40 AM
Hi,
No joy tried the suggestion and zoom does not start up at all.
Where the following does. Reposting as the one last night had various notes as I was trying differentvariations

avar = pld3
print(avar)

local file = io.open(avar, "rb") --checking if file is on hard drive
if file then file:close()


avar1 = [[/Mode Fullscreen ]]
print (avar1)
avar = [[/f ]]..[["]]..avar..[["]]

print("found ".. avar)

win.ShellExecuteEx("zplayer.exe", avar ,[[C:\Program Files (x86)\Zoom Player]] ,win.SW_SHOWNORMAL )

Denon:VCR1 ()
NetRemote.Jump("DVD Player", "DVD Playing")

else
NetRemote.Jump("DVD Player", "DVD Not Found") -- jump to page on Netremote that warns no Hard Drive
print("not found "..avar)
end