PDA

View Full Version : NetRemote 1.1 and Windows 7



Xenomatic
April 24th, 2010, 11:15 AM
This may not be the best place for this thread, but I couldn't find one for NetRemote 1.1.

It's been a few years since I've been on the forum. I'm still using NetRemote 1.1.0.44 and Girder 3.3! (I'm a cheap bastage, I know, but it does what I need it to do :-))

At least it has up until now. I updated my HTPC to Windows 7 and have not been able to get the PPC to connect to the computer-to-computer ad hoc wireless network on the Windows 7 PC.

That's not entirely correct. It proves it can connect because the ad hoc network auto-connects as soon as I push any button on the PPC interface. The problem seems to be that it will not communicate with Girder or MediaBridge after it has hooked up to the network. The local windows client works fine, just the PPC fails to trigger any actions.

It does still work on the old windows XP PC that's being decommissioned, but I've spent hours trying to get it to work on the new Windows 7 box.

The HTPC also has a wired connection (192.168.0.x), but it is on a separate network from the wireless (192.168.200.x). I am not using a wireless router and have never needed to.

I guess my question is, will 1.1 on the PDA (Dell Axim) work with Windows 7? If so, is there some trick to setting up the ad hoc network that I haven't found yet?

Any other helpful suggestions will also be greatly appreciated. Thanks...

Xenomatic
April 25th, 2010, 02:21 PM
Maybe I'm the last person to still be using 1.1, so maybe someone can share a story about a similar issue with a newer version?

Thanks,
Xeno

Rob H
April 25th, 2010, 04:37 PM
You may want to test the trial version of NetRemote 2 to see if that works for you. If you get the same issue I can try to fix that.

Xenomatic
April 25th, 2010, 07:41 PM
Will do. In addition to installing the PPC version on my PDA, do I need to install anything new on the Windows 7 PC?

Thanks,
Lonnie

Rob H
April 26th, 2010, 04:47 PM
No, that should be enough

Xenomatic
April 27th, 2010, 10:04 AM
Hi Rob,

I installed 2.0 on the PDA and tried the test button on the Girder plug-in. It shows no connection even though the PDA appears to be connected to the ad hoc wireless network running on the Windows 7 PC.

Also, Girder does not show any indicators when I press any of the buttons on the PDA. It does work when I use the local windows PC client (still 1.1).

What next?

Thanks,
Lonnie

Rob H
April 27th, 2010, 01:18 PM
Hmm... wonder if it's a firewall issue? Does the PDA show up on the same subnet as the PC? Quite often it won't in my experience.

Xenomatic
April 27th, 2010, 02:11 PM
Hi Rob,

The firewall is off and I don't have a wireless router or firewall in the path. I just have the PC and the PDA. During my testing I have created several types of computer to computer wireless networks (ad hoc) networks on the Windows 7 PC. One connects automatically as a new device joins. This is how I know the PDA will at least join the network.

Unfortunately there is no evidence that the PC is receiving any of the transmitted packets, either in the network status window or in Girder. The PDA never shows up as a client in MediaBridge either the way the local PC client does. I have the same basic setup on my old Windows XP box and it all works fine.

I've done a ton of research but can't find that I've done anything wrong but obviously I'm missing something, a setting or permissions or something that 7 needs that XP didn't.

I though maybe there was an incompatibility between the older 1.1 version and the 2.0 version too but...

Rob H
April 27th, 2010, 04:37 PM
Can you ping the PDA from the windows machine?

Xenomatic
April 27th, 2010, 11:18 PM
Nope, it won't reply to a ping. It is on the same subnet as the PC. I typically use static IP's on my equipment and the PDA is no different. I set the new PC up with the same static IP as the old unit to keep my configurations to a minimum.

This makes it seem like the PDA is not connecting to the network, but that doesn't explain why Windows 7 will activate a persistent ad hoc network that's waiting on a device when I start NetRemote and press a button.

I also checked the drivers and config utility for the Linksys WCF12 CF card wifi adaptor that I have in the Dell Axim PDA. It was up to date, and like I say, it still works fine on the old XP system whenever I turn it on to test it.

I also added a wireless access point (firewall is off) this afternoon. It seems to have helped the connection stability on the Windows PC side of things, but still no luck with the connection from the PDA.

I've gotten 2 other remote systems to work using the same wireless network and connections (using my iPhone as the PDA), but I've got a lot of time invested in the CCF and GML's and I don't want to switch systems if I can help it.

I also made sure the default host and the Girder instance were pointing to the same IP address as the host PC.

Any other ideas? Does anyone else have an Axim with a WCF12 card working with a Windows 7 host?

Xenomatic
April 28th, 2010, 10:27 AM
Rob, I got it working. After adding the $30 wireless router as an access point, I changed the settings on the WCF12 card on my PDA to Infrastructure. It clearly associated with the MAC address on the WAP at this point and I was then able to control Girder and connect to MediaBridge.

I guess I will re-install 1.1 on the PDA and try that again. After updating to 2.0, some of the colors on my UI were blue, so I think I will return to my old tried and true. (rhyme not intentional) :-)

Thanks very much for your help.

L

Rob H
April 28th, 2010, 05:00 PM
Glad you've got it working - it's very puzzling, but it definitely sounds like something wasn't routing packets correctly.

You can probably fix the colour issue by loading the CCF into NetRemote Designer and saving in a newer version of the CCF format. But I'm guessing you'll be sticking with 1.1