PDA

View Full Version : GIP on PPC possibile bug?



pfeifer
January 19th, 2011, 05:43 AM
After the use of GIP under Girder, I am playing on some implementation on GIP under NetRemote for PPC and PC.

After solved the first problem showed here
http://www.promixis.com/forums/showthread.php?t=21006

I, probably discovered, another little bug.

I use the end of message delimiter ##. Under Girder works very well, but under NetRemote when the message have a single # GIP call the callback function.

In this moment I use a workaround, but if Promixis would check/solve it for me it's very powerfull.

Bye

Sandro

pfeifer
January 28th, 2011, 05:29 AM
Tim, 9 days .....

tmorten
January 28th, 2011, 10:23 AM
Is there a reason you need delimiters with repeated chars? If so, can you string sub them for something else?

pfeifer
January 29th, 2011, 09:32 AM
Of course:

I have the following messages:

*16*13*103##
*#22*2#3*12*0*10##

The first is captured right

the second no becouse GIP spit the message in 22*2 , 3*12*0*10

Just for your checks: GIP in Girder work fine.

Bye
Sandro

tmorten
January 29th, 2011, 10:08 AM
Gotcha. I appreciate the heads-up; just wanted to make sure that you have an approach that's working for you.

Right now, our focus is on forward-looking projects. If folks encounter show-stoppers on the current release, we could do a point-release to address. This particular case seems straight-forward to work around, but I definitely appreciate being made aware of it.

Best Regards,
Tim