PDA

View Full Version : Issues with delay



theengine
March 5th, 2011, 08:54 PM
Maybe (ok AM) doing this wrong to have a panel jump after a delay.

I have a button that runs a progress bar countdown and that works.

I want the button to delay a panel jump while the progress bar is counting down
and then jump to a new panel 1 second after the progress bar stops.

But when I put those three together in the button action designer, the entire
thing freezes (the graphic for the button down press just sticks) then after the
delay the panel jumps.

How do I make it so the delay does not shut everything down?

theengine
March 5th, 2011, 10:05 PM
Ok so in reading Ive discovered that netremote does not draw its display when excuting a lua script.

So I tried the wait for variable.

I set the {projtimer_progress} frame to display the countdown from my progress bar thinking that wait for variable would see it hit 1 then do the next command in the action list which is a panel jump....seems logical but what do I know, it does not work.

tmorten
March 6th, 2011, 09:25 AM
One approach to animate a progress bar would be to drive it from Girder: have Girder change the value of a NetRemote variable, and use that variable on the NetRemote side as the index for what image to be displayed.

Cheers,
Tim

theengine
March 6th, 2011, 10:22 AM
I have the progress bar working fine as well as the countdown timer if I wanted, its continuing the action list from the original button press thats got me stuck.

Thanks

tmorten
March 6th, 2011, 10:52 AM
You could try setting a timer from the last code in your flow that you do have executing.

Cheers,
Tim