PDA

View Full Version : Ron: I have found a possible bug in NR/G5



jwilson56
December 15th, 2011, 04:44 PM
Well here is the issue. I am updating some NR image variables from a Girder LUA script. All works well until I put the laptop running NR to sleep. Here is the log when that happens:


Time Date Source Details Payloads
17:37:24:796 12/15/2011 NetRemote Error: Connection Closed sending image variable pandora-cover
17:37:23:968 12/15/2011 Grab&Parse All Lua Success (Nothing Triggered)Grace.gml:\Metadata\New\Grab&Parse All
17:37:23:218 12/15/2011 Girder Polling_Metadate
17:37:10:390 12/15/2011 NetRemote Exiting feedback thread for toshiba-nr
17:37:10:390 12/15/2011 NetRemote Closing client for toshiba-nr
17:37:10:390 12/15/2011 NetRemote Unregistering NetRemote client 192.168.2.215:1047

It unregisters the NR client but it doesn't seem to update the client list for sending the image variables to ALL and you get these error messages in the log.

Any chance there is something I am overlooking or maybe something I could add to get it to update the client list. Lastly if neither can we see a fix for this?

I am running the latest Girder and NR


Thanks

jwilson56
December 17th, 2011, 08:17 PM
Bump for Ron's attention

Ron
December 21st, 2011, 08:45 PM
Does that message from then on happen for each variable update you do in Girder?

jwilson56
December 21st, 2011, 10:11 PM
It seems to only happen with the Setimage actions. Harleydude sent me a script I modified to check for which ones were actually connected and only send to them. But I would still consider that a bug.