PDA

View Full Version : newbie needs help getting started with Girder-5 and PIR-1



Mark Weber
March 17th, 2012, 02:31 PM
I have -
o) Windows 7 computer
o) PIR-1
o) Girder 5
o) Tek Pal remote

I want to use my remote to control my Windows 7 computer. I have installed Girder 5, read instructions, and plugged in the PIR-1. I can't get Girder 5 to see this remote (or another one that I tried).

The wizard directs me to install a plug-in, but I cannot find the plug-in to install. I seem to be missing something very basic.

Please help.

Ron
March 17th, 2012, 02:57 PM
Which wizard are you talking about?

Let's also make sure you hardware and drivers are uptodate.

Download: http://www.promixis.com/forums/showthread.php?21281-PIR-1-Firmware-Update-Promixis-IR-Studio

This should show your PIR-1 (look at the status bar of the application). It should say the firmware version. The latest version is 5. If you are not on 5 update to it.

Next update the Girder PIR-1 driver: http://promixis.com/pir-1.0.4.zip

In Girder (under view->Settings->plugins) enable the PIR-1 plugin.

Now press a button on a remote while pointing at the PIR-1. Inside Girder's log view (View->logger) you should see events coming in.

Mark Weber
March 17th, 2012, 03:56 PM
Thanks. The step I was missing was the "enable the PIR-1 plugin".
After enabling the PIR-1 plug-in, I was seeing commands come across the logger.

Then, I downloaded the Promixis IR Studio, to check my firmware version, as you suggested. It was version 5. I clicked on the PIR-1 Firmware upgrader, to see what is there. It says COM1 (no other com ports); my PIR-1 is USB.

Now, the firmware version is not being displayed on the status line of IR Studio.
And, Girder 5 is no longer seeing my remote.

I have a USB hard drive connected. Could it be interfering?

What next?

Mark Weber
March 17th, 2012, 04:05 PM
I rebooted; no help. I unplugged/replugged the PIR-1 and now it is talking again.
Yeah.

My remote gives different codes every time I hit the buttons.
I hit VOL+ button, get 3 lines.
Hit it again, and get 3 different (but similar lines).

How do I deal with this?

Ron
March 17th, 2012, 05:06 PM
When you pressed the firmware button you place the PIR-1 in USB-to-Serial mode and Girder won't find it until you unplug it. But you figured that out.

Did you update the PIR-1 driver? (http://promixis.com/pir-1.0.4.zip)

Mark Weber
March 17th, 2012, 05:32 PM
No I have not updated the PIR-1 driver.
I have downloaded the zip file, but I could not find instructions on how to update the drivers.

Can you point me at the instructions?

Ron
March 17th, 2012, 05:42 PM
Some docs are here: http://promixis.com/pir-1_doc.php

Simply unzip the contents of that zip file into the Girder\Plugins directory. Make sure you closed Girder fully before you do so.

Mark Weber
March 17th, 2012, 06:36 PM
Okay, thanks. I have updated drivers.

Another question -

Girder does not seem to be able to "learn" my Tek Pal remote. I tried another remote, and Girder learned some keys on it. The Tek Pal is a large-button remote for a vision-impaired person. Do you know if Girder should be able to learn this remote? The logger shows that the remote is sending stuff, but Girder cannot seem to figure it out. If this remote is not supported, is there another large-button remote that Girder can use?

Ron
March 17th, 2012, 07:29 PM
Try using the IR Studio to learn. It has a better algorithm built in. Then you can copy the generated CCF (ir codes) over to Girder for use.

Mark Weber
March 17th, 2012, 07:54 PM
Thanks.

Can you give me some hints on how to use IR Studio?
"Help" is not working. Or, if you have some help files, I could grab those.
Is "help" supposed to work? I can re-install if that would get it going.

I tried "capture IR", "Capture Modulation", and "Calculate CCF" but I haven't been successful.
What steps do I follow?
Do I hold down the remote key, or just press it?

Ron
March 17th, 2012, 07:59 PM
Well the tactics vary depending on how tricky the remote is. First you click "Learn IR". Typically you press and hold the remote. You should see a wave form appear on the screen. If you zoom out (mouse scroll wheel) you should see a repeated pattern. Either way click save as in the file menu and attach the file to your next post on the forum so I can have a look. (You might have to zip up the file for it to attach).

Mark Weber
March 17th, 2012, 08:14 PM
Thanks. Here is the file.
I renamed the .pir into .txt to get past the watchdog.

Ron
March 17th, 2012, 08:29 PM
Ah this is an interesting encoding. Can you copy and paste this CCF into a PIR-1 send action. Send it output out the front and see if it controls your hardware

0000 0049 0016 0005 0001 006E 0001 006E 0001 006E 0001 00DD 0001 006E 0001 00DD 0001 006E 0001 00DD 0001 00DD 0001 006E 0001 084A 0001 006E 0001 006E 0001 006E 0001 00DD 0001 006E 0001 00DD 0001 006E 0001 00DD 0001 00DD 0001 006E 0001 161B 0001 006E 0001 006E 0001 006E 0001 00DD 0001 2848

If it doesn't work on the first try increase the repeat count.

This page shows you how to create a PIR-1 send action: http://promixis.com/pir-1_doc.php

Mark Weber
March 17th, 2012, 08:37 PM
In parallel with getting Girder to listen to my remote, I'm trying to get Girder to talk to VLC. I have VLC installed and it's working fine. The pre-configured Girder stuff that talks to VLC is not working. Some issues -

1) The controls are not able to find VLC. I've figured out how to use the window picker to get past that.

2) Should I enable the "use lau scripting" stuff under VLC? I don't know if that's how you guys set it up or not.

3) The "VLC | startup | focus" works, but nothing else I've tried does.

What is the general plan of attack? Use VLC lau scripting or keyboard spoofing or something else?

Also, after I've played with it a while, the "test action (f5)" command stops working completely. I have to reboot to get it working again.

Ron
March 17th, 2012, 08:44 PM
Not sure why test action would stop working. Have you tried restarting Girder or VLC alone.

I remember seeing VLC releasing a new major release just recently. So yes I'm not surprised it's not working well. They redid the interface.

1. Good.

2. I don't think so

3. Ok.

General plan of attack. First make sure you have the 32bit version of VLC. Try using command capture feature in Girder. If that doesn't work go with keyboard. There are a few ways/options to do keyboard experiment. If that fails go with mouse emulation. If all else fails see if more advanced integration is possible (e.g. writing a plugin for VLC and Girder to communicate)

Mark Weber
March 17th, 2012, 11:09 PM
I re-installed VLC; it is now 32 bit for sure (I think it was before).
Does the VLC interface work for you?

I tried using Command Capture but I get three dialogs in rapid succession -
"Watch" dialog, "Open file failed"
"Watch" dialog, "Memory map failed"
"Watch" dialog, "Capture Mute failed"

I tried the calculator example from the documentation; could not get it to work as described. The only application showing up in the command capture window is girder.exe

Ron
March 18th, 2012, 07:54 AM
Note did you see the CCF code I sent a few replies up?

Calculator example won't work if you are on 64 bit windows. We are working on a solution to that.

Can you make sure that you are administrator when running Girder? Command capture of 32 bit apps should at least not give any errors (it doesn't on my windows 7 64 bit test machine )

Mark Weber
March 18th, 2012, 12:08 PM
Because of all the trouble I've been having, I re-installed Girder without the driver updates.

Things now work quite a bit better; I'm not seeing the dialog boxes and the "test" command has stopped giving trouble. So either I didn't update correctly or there is something broken in the driver updates. To do the update, I simply expanded the zip file using Windows Explorer and copied the luascript and plugins folders and the boost*dll files on top of the corresponding files in the Girder install folder. Is this the right way to update?

I just saw your note about 64-bit apps. Yes, I am administrator while running. I guess it is possible that the trouble I was having was on 64-bit apps, but I don't know for sure. My Girder is new; should I still try to redo the update?


I have been able to create some controls that, when I hit the "test" button, do the right thing. I've still got a ways to go to get it working like I need, but making progress on the Girder to VLC side. I am creating a "My VLC" folder with the various controls in it. I created "play/pause", "mute", "application volume up", "application volume down" actions that, when I test, do what I want.

========

Generally, the remote is set up in the Event Mapping Editor, right? It's confusing because the Learn in that editor does not seem as sophisticated as the "PIR | Send CCF" method on the main view.

I am still having trouble getting the remote commands to be recognized. The CCF string you sent me did not seem to work. Is the decoded name of the command supposed to show up somewhere, such as in the logger window? For "details", I'm getting hex codes. Any way to see if the codes are being interpreted properly?

You said this remote has an "interesting" encoding. Do you think it is going to work? It is a programmable remote; I've tried other settings, but can't get anything going.

I will be experimenting with another remote just to see if I can get it going.

Mark Weber
March 18th, 2012, 02:35 PM
I have not been able to get Girder to recognize any buttons on other remotes. I've tried Learn on both the Event Mapping Editor and on the "PIR | Send CCF". The Event Mapping Editor claims to learn the buttons with one press, but the code does not work. I've tried copying the code from the Learn on the "PIR | Send CCF", but I'm apparently not getting the mechanics right. The <unassigned> string comes back after I paste something into the "Eventstring" window.

Is there a way to "Learn" then test immediately, without going through the other layers? I'm trying to narrow down the problem.

Ron
March 18th, 2012, 02:43 PM
There are two different modes. IR reception mode which returns a hash for the received IR code. This is the normal mode the PIR-1 operates in. These hashes cannot be used for sending codes, only receiving. This is what shows up in the log window.

The second mode is learn mode. This is where you fully analyze a IR signal so you can send it back out again. You can use the built-in learn functionality as described here:
http://promixis.com/pir-1_doc.php

Or for a better analysis use IR studio and then copy and paste the CCF codes into the Send IR actions created above.

Start with fully learning IR codes.

Mark Weber
March 18th, 2012, 03:46 PM
Here is a screen-shot of my various windows.

Steps I took -

o) "capture IR" in IR studio
o) copy hex string to "testing | stop-button | Send CCF"
o) hit the remote button again, with logger on

There may be something very basic that I am missing.

=====

Did you see my post on the driver updates?

I am currently a fresh download of Girder, but without driver updates. Should I update? If yes, what may have gone wrong with my previous update? See that post for how I did it.

Ron
March 18th, 2012, 04:24 PM
One thing that looks like it is messing you up. After you learn inside IR Studio make sure to toggle LEARN IR off. Otherwise Girder cannot send the IR code. Beyond that you should update the PIR plugin inside Girder. Looks like you are very close.

Mark Weber
March 18th, 2012, 05:34 PM
It's basically working now.
Whoo hoo!

A couple of questions -

1) It seems I need to create a "Send CCF" action in the main window for the express purpose of getting the hash for a CCF calculated by IR studio. Then, I use the Event Mapping, in which the "learn" simply comes up with the hash from an already learned CCF. Do I have this right? Is there a better way?

2) The log in the attached screen shot is from a single-button press on the remote. There is a lot of traffic that perhaps should be cleaned up. I have set the anti-repeat to 1000 ms, which helped, but I'm still getting the traffic. I have also disabled all the nodes on the main window except for "My VLC". Should I bother with this?

Ron
March 19th, 2012, 09:18 AM
1. As I said in a previous post there are two different ways the PIR-1 works. Learning and Normal mode. IR Studio does Learning mode. This gives you a CCF. CCF's are used for sending IR codes out from the PIR-1. In normal mode you get a HASH for each button press. This is used for controlling your computer from a IR remote. When using the event mapper you are working in normal mode, you store HASHES. So, no, you do not need to create a send CCF action for the event mapper to work. Send CCF actions are used to send out CCF codes from the PIR-1.

2. The logs looks just fine. I wouldn't worry about it.

Good work! Looks like you rolled over the initial 'how on earth does this all work' bump :)

Mark Weber
March 20th, 2012, 08:27 PM
Hey, thanks for all your help. Things are working great.

Maybe my last question -
When I shutdown my Windows 7 64-bit, I get a dialog out during shutdown complaining about a Girder error. Is there anything I can do about it?

Ron
March 21st, 2012, 08:20 AM
You could give Girder 5.1 a try. (It's available on the forum) install into a different directory from Girder 5.0

Cristofski
May 25th, 2012, 06:38 PM
Maybe this isn't the place for this question, but I didn't want to create another "newbie" thread. Here's my issue, I've been tasked with creating a Windows Embedded image for a digital signage device. The image is built and the general OS seems fine. However, getting Girder to function properly is becoming a nightmare. nothing seems to work, but some of that is because I'm new to girder. I do have other devices that will use the same commands. Essentially what I want to do is export the functioning complete configuration and import it onto the new device. As far as I can see, there is no simple way to do this. Yes there are export options, but they only seem to export pieces of what i want. When I try to look for the location of fies that look good, there is no browse to or pproperties option. Can someone please help? I'm sure there are easy answers to my struggles, I just don't knwo where to look. When I do a search on the C: of the functioning device i find various *.gml, *.cfg, *.map, and *.lua files, but it's tough to tell what each of these correspond to.


thanks in advance!!

Ron
May 25th, 2012, 07:37 PM
We've created windows embedded images before. There is no 'simple' way to create what you are looking for. However by copying the GML files, the registry and the LOCAL_APP directory you should get a long way. What errors are you running into after your first pass at this?

Cristofski
June 4th, 2012, 02:14 PM
The issue isn't that I'm receiving errors and more so it doesn't work as expected. I'm not adding girder as a component to the embedded image. I'm installing it to the machine once the image is built. The issue is more that even though I'm copying the files and directories, setting don't match on the two devices. In other words, I have device A that functions properly, and device B that I believe should function the same, but it doesn't. I'm assuming there is more to it than just copying files. I just don't know what I need to do once those are on there.

Ron
June 4th, 2012, 02:41 PM
I want to help, but you'll have to be more specific. What does not work exactly or which setting is different?

Cristofski
June 4th, 2012, 04:51 PM
OK, for example, to start with I have one device that is functioning as designed. I copy the *.gml file over to the new device. I open up girder and point to that same *.gml that I've just copied locally. I would assume that the settings listed below that gml would match, but they don't. Is there something I need to add to that in order for that to work?

Ron
June 4th, 2012, 05:36 PM
The GML files holds the interactions between devices, actions and events. The devices themselves are defined in the configuration directories. To find out the location for that directory on your source and target machine run this command on both:


print(gir.GetConfigDirectory())

On my machine that gives C:\Users\ron\AppData\Roaming\Promixis\Girder\5\Con fig\

Note this might be different even between your two machines.

Exit girder and zip it up from the source and with Girder fully exited unzip it in the target directory.

Also please make sure you have all the HKCU\Software\Promixis\Girder\5\ stuff and HKLM\Software\Promixis\Girder\5\