PDA

View Full Version : Girder 5 RunScript error



b4d1
December 1st, 2012, 12:37 PM
Hi,
I'm trying to install a PoKeys56E device (www.poscope.com) with Girder 5.1.0 Build 590 under windows xp.
I got an error into girder interactive console (see attached file)
The lua script runs perfectly under LuaForWindows_v5.1.4-46.
I guess it could be a lua version problem.
Best regards
b4d1

Tieske8
December 2nd, 2012, 02:56 AM
Welcome to Promixis Girder 5.1.0 build 590
Pokeys56E-1 - init 1.0.0
PoKeysDevice_DLL object created
Connected to PoKeys56E-1 at 192.168.123.49
Got tick value
Serial Error (RunScript, C:\Program Files\Promixis\Girder51\/plugins/serial/Pokey56e-1_init.lua, 2): COM error:(.\src\library\tLuaCOM.cpp,403):Paramètre incorrect.
stack traceback:
[C]: in function `SetPinData'
/plugins/serial/Pokey56e-1_init.lua:43: in main chunk

If anything I would expect it to be a LuaCOM problem. Be aware that Lua for Windows is Lua 5.1 and Girder is Lua 5.0, though there is no obvious incompatible Lua code in the lua file.
Even the LuaCOM part seems to work as the device is able to connect and get some data. My first guess would be to check the LuaCOM versions used by Girder and Lua for Windows. Unfortunately I have no COM knowledge whatsoever...

HTH

Tieske8
December 2nd, 2012, 03:00 AM
Just a thought; you might want to try Girder 5.0 latest as well, 5.1 is fairly new and I don't know how well the LuaCOM has been tested with that.

b4d1
December 2nd, 2012, 05:45 AM
Hi Tieske8,
Thanks for your help.
I found that actual Girder 5.1 uses a 1.2 LuaCom built-in version and my code needs a 1.4 LuaCom.
May be Ron could help me?
Best regards,
b4d1

Tieske8
December 2nd, 2012, 09:09 AM
The website showed a detailed protocol to ocntrol the device. So it probably is possible to use the Girder Transport mechanism to talk to it, but then your up to quite some work...

b4d1
December 2nd, 2012, 11:46 AM
Tieske8 you are right, i did it first using Girder Transport but there was more coding work.

b4d1
December 4th, 2012, 08:10 AM
Hi,
Ron could you answer to my first request concerning luacom built-it version into Girder? Is it possible to have a 1.4 one installed?
I have not enough lua skills to develop a specific transport protocol.
Best regards,
b4d1

Ron
December 4th, 2012, 08:15 AM
LuaCOM 1.4 says it's compatible with Lua 5.1. Girder 5 and 5.1 both use Lua 5.0. Also note using LuaCom is not as stable as you might want it to be.

b4d1
December 4th, 2012, 08:33 AM
Thanks Ron for your quick answer.
Could you give me the luacom built-in version for Girder 5.1?