PDA

View Full Version : Lua Subsystem did not respond



watch
August 17th, 2013, 03:34 AM
I get this error message via Girder Watchdog on a Windows XP re-boot & Girder restart. Also, the Lua Console does not provide feedback - every line is "Node".

Is there a likely problem with a specific file that I should replace?

Ron
August 19th, 2013, 09:13 AM
Somewhere you are blocking Lua, which is making Girder unable to access Lua. This could be in a lot of places.

Do you use Lua?

watch
August 19th, 2013, 06:10 PM
Lua is only in some script actions (that are still working).

The only thing that was done on the PC that is dedicated to Girder, was a Microsoft patch to XP.

Ron
August 19th, 2013, 07:18 PM
oh boy.

I'm afraid the only way to diagnose this one is to start eliminating possibilities. So unload all plugins (uncheck them). Then exit and re-start Girder. Does it work now? If not go to component manager disable all components and stop and restart Girder again. If it still is giving the error rename the lua directory and restart Girder. Surely by now it must be working. Then once it is working slowly start re-enabling functionality.

Did you have a look at the FAQ? There are a few application that mess around with Girder 5. Dropbox and FLV come to mind.

watch
August 20th, 2013, 09:20 PM
Whatever was blocking Lua seems to have been cleared. I tried a few different things - I think the cause was a Microsoft "security essentials" tool (now deleted) that must have been part of the most recent upgrade.

I had to re-eneable the Elk M1 pluggin (and re-enter the registration) - now my only issue is that it doesn't discover all my Elk config. Console output is as follows;

Welcome to Promixis Girder 5.0.14 build 551
---------- Starting Discovery ----------
---------- Discovery Complete ----------
Error in subscriber callback
...ascript\DeviceManager/Providers/ElkM1EZ8Provider.lua:548: attempt to concatenate field `Defined' (a nil value)
stack traceback:
...les\Promixis\Girder5\luascript\Classes/Publisher.lua:28: in function <...les\Promixis\Girder5\luascript\Classes/Publisher.lua:25>
...ascript\DeviceManager/Providers/ElkM1EZ8Provider.lua:548: in function `AddZones'
...ascript\DeviceManager/Providers/ElkM1EZ8Provider.lua:114: in function `AddDevicesNow'
...ascript\DeviceManager/Providers/ElkM1EZ8Provider.lua:158: in function `ComponentEventHandler'
...luascript\DeviceManager/Providers/ComponentBased.lua:30: in function <...luascript\DeviceManager/Providers/ComponentBased.lua:30>
...les\Promixis\Girder5\luascript\Classes/Publisher.lua:37: in function <...les\Promixis\Girder5\luascript\Classes/Publisher.lua:36>
[C]: in function `xpcall'
...les\Promixis\Girder5\luascript\Classes/Publisher.lua:40: in function <...les\Promixis\Girder5\luascript\Classes/Publisher.lua:32>
...les\Promixis\Girder5\luascript\Classes/Publisher.lua:151: in function `SendEvent'
...les\Promixis\Girder5\luascript\Classes/Publisher.lua:138: in function `Event'
...omixis\Girder5\luascript\Components/Classes/Base.lua:473: in function `Event'
...
...Promixis\Girder5\luascript\Classes/ElkM1EZ8Class.lua:912: in function <...Promixis\Girder5\luascript\Classes/ElkM1EZ8Class.lua:904>
[C]: in function `pcall'
...Promixis\Girder5\luascript\Classes/ElkM1EZ8Class.lua:519: in function <...Promixis\Girder5\luascript\Classes/ElkM1EZ8Class.lua:470>
(tail call): ?
[C]: in function `xpcall'
...ogram Files\Promixis\Girder5\luascript\protected.lua:132 : in function `protect'
...romixis\Girder5\luascript\Classes/Transport/Core.lua:1073: in function `DoOnMethod'
...romixis\Girder5\luascript\Classes/Transport/Core.lua:1144: in function `DoOnReceiveData'
...romixis\Girder5\luascript\Classes/Transport/Core.lua:840: in function `EventHandler'
...romixis\Girder5\luascript\Classes/Transport/Core.lua:536: in function <...romixis\Girder5\luascript\Classes/Transport/Core.lua:533>

Ron
August 21st, 2013, 08:12 AM
change line 548 of luascript/DeviceManager/Providers/ElkM1EZ8Provider.lua:548

to:
Description = 'Security Zone - '..(zone.Defined or 'This is the offending zone'),

not entirely sure but I think this might help.

watch
August 22nd, 2013, 08:09 AM
Thankyou! Seems to have resolved the problem - only been running for a short time but no issues with discovery on the Elk M1 now.

The Console still doesn't reflect Girder Events though - is their a "switch" I can check or a file that may need to be reloaded? I set this up a couple of years ago and I don't recall having made any changes to the standard install.