PDA

View Full Version : Girder and Windows 8.1 Cannot Save Settings Error



glynor
October 20th, 2013, 10:50 AM
I upgraded my HTPC to Windows 8.1 this past week, and I've been having one problem with Girder 5. When it launches, I get an error dialog that says "Cannot SaveSettings".

I can't find anything that doesn't actually work properly. The error dialog seems to have something to do with a particular plugin I have loaded, though I'm not positive. I tried a full uninstall of Girder, and upon reinstall it doesn't do it. However, when I went in and enabled the plugins I need (which includes USB-UIRT and Generic X10), then it started doing it immediately. Assuming that is correct, I haven't actually tracked down which specific plugin causes it (though I can if it would help).

Any ideas on fixing it? As I said... Everything seems to be working right. But the dialog is annoying at every boot, and Girder itself doesn't seem to work until I click "Ok" on the dialog.

I'm also planning to switch over to Girder 6 (which doesn't do it thus far, and seems to be much more well behaved in my brief tests), but I can't figure out how to get it going with my Firefly remote currently (http://www.promixis.com/forums/showthread.php?21620-Generic-X10-%28Snapstream-Firefly%29).

glynor
October 21st, 2013, 08:05 PM
I think maybe it is the Generic X10 plugin (which I need because I have a Snapstream Firefly remote).

I think, maybe, because it is trying to use the mapping from c:\Program Files (x86)\Promixis\Girder5\Maps\ and it doesn't have permission. But I'm (a) not sure, and (b) not sure I can move that (it is an import/export in the Event Mapping dialog, not an open/close). I tried forcing my user account to have full permissions on the whole c:\Program Files (x86)\Promixis\ folder tree (which I'd rather not do if not forced), but it didn't help...

Ron
October 21st, 2013, 08:47 PM
If running as administrator once doesn't help I'm afraid I don't know what to do about it.

"Gouda is the only cheese"