View Full Version : Doesn't 5.1 save position of logger and LUA console windows in Windows 7 x64?

December 26th, 2014, 12:08 PM
I'm setting up a few new VMs with Windows 7 x64 to replace my rather aging XP VM's as automation servers (the hosts are Windows Server R2, with VMWare running on Xeon CPU's with 32 gig RAM - not that I think that matters, I just like to brag about it...), and I've hit one annoying snag: I want the windows to be like I have them on every start, and I just can't get the stuff to pop up like I have them when I close Girder. Is there a trick here, or is there a bug? (Yeah, I know Microsoft would call it a feature, but Promixis isn't Microsoft!)

December 26th, 2014, 12:24 PM
You mean Girder isn't remembering it's last window position?

December 26th, 2014, 12:25 PM
Hi, Ron! Happy holidays! :) Yeah, that's what I mean. Not even what windows that should be up. When it starts only the main window is up, even though that's the correct size from what I set it to.

December 26th, 2014, 12:27 PM
Happy Holidays Tor.

Well sometimes the main window is the correct size, that would be a bug I guess.

December 26th, 2014, 12:36 PM
To elaborate further. I'm not sure why the logger and lua console don't remember their position. Unfortunately no more work is done on the G5 code base. So you'll have to just live with what it does currently.

December 26th, 2014, 12:41 PM
Too bad. No tricks I can try to make it remember to push up the logger and console, and have them where I want to? Or maybe the simplest way would be to use window manipulation on Girder itself on startup?

December 26th, 2014, 12:44 PM
IIRC Girder stores it's location in the registry. Why that is failing for those Windows on Windows 7 is not clear to me. Try running as admin set the positions correctly close Girder fully and restart, hope for the best.

December 26th, 2014, 01:07 PM
Nope, did not help, I'm afraid. I even copied the reg settings from the XP VM where it worked, and it didn't even open the logger and console. So I tried making a quick and dirty solution with sending F4 to Girder as a keystroke and then moving and resizing the logger window. Weirdly enough I had to use "match foreground task", I couldn't target the Girder main window. Is there a sub window I should really be targeting?

December 27th, 2014, 07:40 AM
I've had this issue for ages, already on WinXP. Gave up on it.

(also running Win7 x64 these days)