View Full Version : Keyboard send issues

March 27th, 2015, 04:47 PM
I am having a problem with sending key strokes after upgrading to from I have Girder running on two Windows systems. One has my PIR connected and it sends events to the second which is my HTPC. Girder on the HTPC then sends key presses from the events to control my media player (JRiver). I simply used Keyboard > Send to Foreground in the past (for months) with no issues.

After the upgrade (also installed a number of Windows updates just for disclosure) key presses no longer happen. I can see the events arrive and the Send to Foreground gets triggered but JRiver does not respond. I can eventually get it working if I restart Girder or I have even managed to get it going by shutting down JRiver manually and then launching it from Girder via an Execute command (this is programmed on one of my remote buttons).

I have tried Send Targeted and Set Focus but nothing seems to work. Any ideas?

March 27th, 2015, 05:00 PM
Can you please downgrade to and check if it works again:



I don't recall any work on the keyboard routines lately. Let me know if it works or not.

March 27th, 2015, 05:41 PM
Ron, thank you. I did the downgrade and it had the same issue so I was able to eliminate Girder. I suspect that a recent JRiver update is the cause. Downgrading was something I wanted to try but didn't know if that would cause an issue. Anyhow I got it working again. It seems that I now have to launch JRiver after Girder. JRiver has always just auto started with Windows and it has worked fine in the past but no longer apparently. I just have Girder launch JRiver now and it seems fine.

Thank you and sorry for the bother.

March 27th, 2015, 07:06 PM
No problem. Glad it's solved!