View Full Version : Get Igors Plugin to work after Wakup from Standby-Mode (W98)

October 13th, 2002, 04:55 PM
maybe you can use the enable/disable device (girder tab) commands instead of F9...

October 13th, 2002, 04:55 PM
I had the problem that after wakeup my system from standby-mode the igor IR plugin doesn't worked anymore. I solved this problem under W98.

Start standby-mode with this command:
1x O.S.-->power management-->Ram-alive forced

For reinitialize the plugin u only have to press 2x F9 for disable/enable Girder. This must be fired OnResumeSuspend:
2x Keyboard-->Special Key: F9

Well after this was solved I had the problem that Girder has to be in Foreground to let this work. Send F9 to the Girder window while it wasn't in foreground doesn't worked for me, so I took the active Window. Therefore I put Girder in Front before going into Standby (O.S.-->Restore).
Now the Problem was that Girder was in foreground after WakUp and i had trouble to put the minimize-command into the Multigroup with 2x F9.
So I did it with the OnGirderEnable Event which is fired with the second F9 key. (Window-->Minimize)

This works pretty fine now. Only problem is that Girder has to be visible in Taskbar (otherwise Restore would not work), maybe some of u know how to Restore it to foreground from SystemTray!?
At the moment I start Girder everytime without minimize it into tray and OnGirderOpen I minimize it.


July 31st, 2004, 08:32 PM
Using enable/disable device make s a lot more sense.
All you need to do is look up the device number. Mine happens to be 267 or something like that.
Works even when Girder is in the task bar.

I like your solution to standby more - really fast!
Before I found this post I used a .bat file and a stand alone program to do that - it was much much slower.