PDA

View Full Version : Action path lost after some time



MarBe
January 5th, 2016, 03:24 PM
Hi, I use more type devices - IR, Z-Wave, Simple transport, on my RaspberryPI Girder 6.
On one device Simple trasport plugin LGTV occure this - after some time some actions on macros ended to work.
The same action on device work.
I checked it, and the result is, that the action lost path to command on device.
I restored the action from device more times at past time, but after some time it stop to work. I tried to save action by path or by id, everytime is it the same.
This behaviour is only on one device on simple transport plugin, but more actions commands on it.
How is possible to resolve it?
At attachment - printscreen with defect action without path to device command, after double click on action is not shown the action on device on window bellow, second - the same command new attached.

Ron
January 5th, 2016, 03:34 PM
Do you have any way to recreate this bug in repeatable steps? Does it only happen on the RPI?

MarBe
January 6th, 2016, 03:43 AM
Sorry, I work only on RPI. I try to recreate bug, find out the cause, but no success. Striking is the fact, that it made only one device on one plugin, on more actions on it. It is possible to check this device?

MarBe
January 11th, 2016, 05:50 AM
This bug is still active. Some last experiences - I added some scripts, disabled Z-Wave plugin, deleted z-wave devices, and binding to actions are away. Simple transport plugin works.
What is possible to do more? Now it is not usable.
Thank you

Ron
January 11th, 2016, 08:29 AM
I'm still not 100% sure how you are getting this bug to happen. If the z-wave device was deleted that you are referring to from the action and you open the action, yes the link will be broken,.. the device is gone after all.

Please can you do a step by step to describe how to make this happen?

MarBe
January 11th, 2016, 08:58 AM
Yes, sorry, I can not describe exact, how is the bug created. I know only:
- all work at first time, booth my simlple transport devices and its actions work well
- I do some operations on girder tree, saving, editting scripts, addigs scripts, enable and disable plugins, deletings z-wave devices, disable z-wave plugin, sometimes I edit the siple transport device or the device get off-line, I edit the device and save it again.
- after some of these actions I try to control my devices, and it works not
- then I know only, that the actions works from device manager, not on my actions tree and if I click on the action on actions tree, on device window is not shown the right action, only header of tree.
Therefore I think, it lost the bindings to the device actions, but the device and the action is not renamed or eddited, only whole plugin device can be saved...
Thank you for help

MarBe
January 11th, 2016, 03:00 PM
Maybe can I help with sending gml on well commands and after lost bindings?
Its crazy, now are lost actions from other plugin too, and not all, only some actions from booth. Other like IR commands are perfect.

Ron
January 11th, 2016, 03:12 PM
send me both the GML and the girder.db file from your Appdata\local\Promixis\Girder 6 directory. -> or equivalent on Linux