PDA

View Full Version : Girder on Raspberry hang up



MarBe
January 16th, 2016, 09:43 AM
Hi, I have trouble with unexpected hang up the girder6 on raspberry.
The system works and after some time it hang up, I cannot to connect to it.
I hope at log is some interesting at attachment.
Thanks
Martin

Ron
January 16th, 2016, 07:20 PM
Your license file is wrong. Please send your /opt/girder/qt/etc/xdg/Promixis/pluginLicenses.conf to support@promixis.com and I'll have a look what is going on.

MarBe
January 18th, 2016, 01:05 PM
Hi, I send it via mail.

Ron
January 18th, 2016, 01:17 PM
Got it,.. having a look...

Ron
January 18th, 2016, 01:24 PM
Ah you are storing the main Girder license in the plugin licenses file. Rename that file to "Girder 6.ini". It should be in the /opt/girder/qt/etc/xdg/Promixis directory.

Does that help?

edit: Make sure you do not have a pluginLicenses.conf file.

MarBe
January 18th, 2016, 04:47 PM
OK, at this directory was "Girder 6.ini" license file and pluginLicenses.conf file, the contens of files was the same. I dont know, how is it happend.

Now are at log these rows
"BackendDevice::selfCall::onStatusChanged / not a function " "onStatusChanged"
"BackendDevice::selfCall::onStatusChanged / not a function " "onStatusChanged"
GirderConnection CA certificate not found, SSL likely not to work. "/opt/girder\ca.crt"
GirderConnection::setDescriptor / WARNING NO PRIVATE KEY. SSL WILL NOT WORK.
65
PluginLicensing::load / could not open file: "/opt/girder/qt/etc/xdg/Promixis/pluginLicenses.conf"

Ron
January 18th, 2016, 04:53 PM
OK, looks fine. Is something still going wrong?

MarBe
January 19th, 2016, 04:01 PM
Unfortunately yes, its hang up. Can you see somethink at log?

Ron
January 19th, 2016, 05:08 PM
Can you zip up your configuration directory and email it to me? ( directory contains girder.db )

Also how long before the hang happens?

MarBe
January 20th, 2016, 10:08 AM
OK, Im waiting for new occurs. But the exact time will be trouble. Is possible to add some log information from system or from girder action?
I cannot to examine hang time, I only have time, when I find it out...

MarBe
January 23rd, 2016, 08:05 AM
Some more hangups, but at log I cannot see anything.
this sure hangs the girder, then the front-end seems to work, I cannot to save my project and the variables do not refresh.
Can you help me, where should I search the girder.db file?

-- Opens a file in read
file = io.open("/home/pi/Desktop/test.lua", "r")

-- sets the default input file as test.lua
io.input(file)

-- prints the first line of the file
print(io.read())

-- closes the open file
io.close(file)

-- Opens a file in append mode
file = io.open("/home/pi/Desktop/test.lua", "a")

-- sets the default output file as test.lua
io.output(file)

-- appends a word test to the last line of the file
io.write("-- End of the test.lua file")

-- closes the open file
io.close(file)

MarBe
February 4th, 2016, 01:15 PM
Hi, now it works long time without any hangs. I disabled z-wave interface, but I dont know, if it was the reason.
The version on raspberry is still 15.1, but on windows 16.2 - when wil be upgraded too?
Thanks

MarBe
March 20th, 2016, 10:47 AM
Hi,
I made some changes at my girder actions tree and simple transport plugin devices, and the hang-up occurs again and often.
Some findngs:
1. the time stamp at Girder logger is no actual. I restarted raspberry and before connection of Girder frontend the timestamp was 14:55:11 and the simple transport plugin not work properly - only shows Sending Heartbeat, but no answer from device, no parse data - at attachment.
After connection of Girder Frontend at 14:55:14 it start to work normally.
I found that the date time on raspberry was incorrect - but should the simpletransport then hot work?

2. The actual Girder project and LG and Harman devices at attachment
What other information can I send you?
Thanks

MarBe
March 21st, 2016, 01:53 PM
Today new hangup, everyday it do not work. I need add some debugger information to the log!
Thank you

MarBe
March 22nd, 2016, 07:00 AM
Last hang-up yesterday, I send some IR commands, and get no response. But after 1 munites Girder wakeup and sends all commands at all.
Today full hangup.
Everytime I check debian, and it works.

Ron
March 23rd, 2016, 11:07 AM
This is tricky to diagnose. But the first thing to do is rule out any all all actions and script that you have added and slowly add things back in until you find the culprit. Go one at a time.

MarBe
March 23rd, 2016, 11:20 AM
OK, I can it to do. But I need some diagnostics tools - write logs, sending mail - that I can better diagnose, what is happenned.
And I still think it is a bug at Girder, it do not hang up with direct my actions. All actions works fine on my testing, but after some time hang the system up.
Last my step was to change MMC card. I had troble with starting the OS wheezy, and this resolve it. But no bug in Girder.
I can make direct connection to girder and PI too with vnc,WinSCP, if you want.
Thanks