PDA

View Full Version : Rpi + VNC -> wacky keyboard only in Girder (asdf = abfh)



declan slater
April 11th, 2016, 11:24 PM
I've been fighting an odd bug using VNC to remote desktop into the Rpi for at least 6 months...

The problem is only when I use Girder, the keyboard is totally screwed up.
The keyboard is fine through remote desktop for the terminal, text editor, web browser...

It is just only screwed up in Girder. Almost all the letters are mapped out totally hosed.
asdf = abfh

It happens on everything I tried (my macbook, pc (win7), and android phone (mocha vnc)).

Rpi is running a fresh latest version (2015-05-05 version) of raspbian wheezy, and I've run into this on older versions of raspbian and dietpi (wheezy) too. Girder is the latest version, I've tried at least 4-5 different fresh installations.

A usb keyboard connected directly to the Rpi works fine in Girder, this problem is only under VNC.

Now that you have the new Jessie build of Girder out, I'll try it on that and see if it has the same problem.

Thanks Ron! Your software is really great! Thanks for continually supporting and upgrading it!

declan slater
April 14th, 2016, 11:06 AM
I currently have found the workaround that I use to be, in VNC: open a text editor on the rpi, type whatever you need to type into Girder into that editor, then copy that and paste into Girder.

Ron
April 14th, 2016, 11:20 AM
This doesn't look like it's Girder specific. Do these give you any idea?

http://blog.yclian.com/2007/12/3-solutions-to-gnomevnc-keyboard.html
http://ubuntuforums.org/archive/index.php/t-1502683.html

Also I've released an updated the RPI (Jessie based) maybe that takes care of the trouble already.

Ron
April 14th, 2016, 11:21 AM
https://www.raspberrypi.org/forums/viewtopic.php?&t=30942
http://www.plugcomputer.org/plugforum/index.php?action=printpage;topic=114.0

declan slater
April 15th, 2016, 10:34 PM
Yep, all those links talk about a global mapping issue across the entire system, screwing with all running programs and the terminal - in the same mannor. The interesting thing about this, is that the problem only shows up when working in Girder on the Rpi, over a VNC terminal (tightvnc or vnc4server).

All this is just because I have a mac laptop, and it runs parrallels too slowly to be fun to use, so I can't run Girder Remote on it.

I tried the Jessie version, same exact problem. Keyboard fine for all programs (including terminal), hosed in Girder.

Even tried andromouse, to control mouse and keyboard from my phone, and vnc to view display. Same exact problem. As soon as you click back to any other running programs, with Girder running in the background, the keys are fine, click back to Girder - keyboard is hosed...

Oh well, don't loose sleep over it, I just wanted to inform on what I tried as workarounds.

Guess I'm stuck setting up a pc on my local network, with Girder Remote and Teamviewer...

I also noticed that the netremote editor (mostly) works on the Rpi now! - it just crashed Girder on Wheezy when I tried to run it. Weird "halo" effects on stuff in it, and netremote is pretty slow on my Rpi2, but it works!

Thanks for the Jessie Build!

declan slater
May 18th, 2016, 12:07 PM
Ok, so after I uninstalled tightvncserver, then installed the new VNC server for rpi that was released somewhat recently, (it grants you access to the actual desktop that goes out the hdmi port, instead of a totally separate virtual one) - so, that FIXED IT -now it works GREAT! No problems with the keyboard at all, and it runs way faster! (even using the free version)

sudo apt-get remove tightvncserver
# if tightvncserver was installed...

curl -L -o VNC.tar.gz https://www.realvnc.com/download/binary/latest/debian/arm/
tar xvf VNC.tar.gz
sudo dpkg -i VNC-Server-5.3.1-Linux-ARM.deb VNC-Viewer-5.3.1-Linux-ARM.deb
#(or change the filenames to match the updated files that were just listed as needed)

sudo vncpasswd -service
#set your password for vnc...

sudo vnclicense -add "licence"
# (insert your licence without quotes you got from here: https://www.realvnc.com/purchase/activate/)

# you also need to run raspi-config and set x to start automatically on boot, or it will not work, as you cannot just startx from a ssh session, it has to be done directly on the Rpi console itself.

sudo systemctl start vncserver-x11-serviced.service
#to start the server...

sudo systemctl stop vncserver-x11-serviced.service
#to stop the server...