PDA

View Full Version : PIR-4 stops responding after some time



aldare
September 17th, 2016, 06:39 AM
Hi again,

I have about 5 Pir-4 devices with 3 Pir-1 devices within one system. Some of them sometimes get to the state it is not able to send a IR command. In log it says "PIR-4 sending...", but there is not successive corresponding "IR Sent" log item.
HW disconnect/reconnect of Pir solves that, but it is not an acceptable solution.
My Pir-4 driver version is 1.1.1, Girder 5
I know it may by difficult to track down what is wrong, but is there any chance this might be solved? Some extended logging, another driver version, Girder 6, or possibility to trigger SW reset of the device when this inoperative state is detected?

Many thanks
Ales

Ron
September 17th, 2016, 02:43 PM
I think we have a solution for that for the PIR-1. I'll see if I can get the PIR-4 firmware updated with the same fix...

Ron
September 20th, 2016, 11:25 AM
If you have a PIR-1 MK2 (bought as of April 2014) use the attached updater. If you have older PIR-1 let me know. PIR-4 fix coming up...

* Load the "Bootloader.gml" file in Girder and trigger the node "New File / Net Group / to bootloader"
* Then after a few seconds click "upgrade.bat"

Ron
September 20th, 2016, 11:33 AM
Looks like some of your orders were prior to April 2014. The file above only works on the MK2 version bought after. I'll provide a hex file for the older units too...

Ron
September 20th, 2016, 12:11 PM
Looking at the PIR-4 code it actually never had the disconnect bug. So this is more likely to be a Girder 5 driver bug. I've attached an updated PIR-1 and PIR-4 driver for Girder 5. Give it a try.

aldare
September 30th, 2016, 03:31 PM
Ron,

thanks for the replies and sorry for the delay, I just returned from holidays.

I actually have problems just with Pir-4, so updating Pir1 probably won't have any effect.
I checked the drivers and they are already in my system, they solved the problem with high cpu some time ago.

I did have the problem meanwhile and found out after Girder restart it was sending signals again. No need to reconnect the USB. So maybe you were right the problem might be in the Girder driver.

The units are used quite heavily, they are sending lots of signals quite often, so there might be some kind of queue overrun or something similar that other users might not experience.

When the problem occurs, the device seems to stay connected and the Girder is responsive. If there was any way how to check the state of the device, query and log some debug info or whatever, we could go this way. If not, I would have to restart it once about every week or two, which is not a disaster, but my HVAC depends on it so it is nothing pleasant.

Thanks again
Ales