PDA

View Full Version : Girder License Path "/etc/xdg/Promixis/"



25TCP
February 28th, 2017, 07:43 PM
Tried to help myself but 8+ hours in asking for help!

I set up Girder 6 on Raspberry Pi about a week ago and it was working great. (Service / back-end on RPi).

My Girder trial license just expired and so I went to put the paid license info in, replacing the trial info that was in
/opt/girder/qt/etc/xdg/Promixis/pluginLicenses.conf

I then saved the file and rebooted but the G6 Service did not load at boot of the RPi.

I then navigated to
/opt/girder and tried
sudo ./Girder6Service and got the following:



pi@raspberrypi:~ $ cd /opt/girder/
pi@raspberrypi:/opt/girder $ sudo ./Girder6Service
Girder License Path "/etc/xdg/Promixis/"

Notice that the license path
/etc/xdg/Promixis/ is not the same as where the license info had been before:
/opt/girder/qt/etc/xdg/Promixis/pluginLicenses.conf

(It was automatically located there when I had initially run the front-end with the trial version since it prompted me for the license. I can still get it to prompt me for a license on the front-end (if I manually remove the license file to test whether it prompts me) but the license doesn't seem to be able to be found when I run the back-end.

When I run
sudo ./Girder6 the front-end opens on the RPi (when in GUI mode) and the other devices I have (Windows 10, Android NetRemote) then see the back-end on the RPi and all is well. As soon as I close the front-end, the connection is lost, which makes sense.

Please can someone help me get back on track here?

I have also tried removing the license files and uninstalling and reinstalling Girder on the RPi but that has not solved the issue. Lots of reboots in between.

I also tried to use the info in this forum post but still no go. (Can't post links yet -- noob :( -- but thread 22141)

Here's the permissions on the file:

pi@raspberrypi:/opt/girder/qt/etc/xdg/Promixis $ ls -l
total 4
-rw-r--r-- 1 root root 127 Feb 28 19:10 pluginLicenses.conf

I'm happy to start fresh given that troubleshooting this may be worse.

Mil gracias.

Ron
February 28th, 2017, 09:13 PM
Sorry you are having trouble!

Can you place the license file in both places just to see if that solves it? Make sure it's world-readable.

25TCP
March 1st, 2017, 11:45 AM
Thank you for the prompt reply.

The files are already in both locations. And there exist identical files Girder 6.ini and pluginLicenses.conf in both places. Demonstrated below. (Four files total, two in each location.)

Aside: Quite frankly, I'm confused about which one is correct since the .ini file is what Windows uses. In any case, having info with both filenames shouldn't cause a conflict, IMHO.

Attached are screenshots of the pluginLicenses.conf files, just so you can make sure I've not done something careless.
70507051

As well, here are results of permissions check of the files.


pi@raspberrypi:/etc/xdg/Promixis $ ls -l
total 8

-rw-r--r-- 1 root root 126 Feb 28 18:59 Girder 6.ini

-rw-r--r-- 1 root root 126 Feb 28 19:49 pluginLicenses.conf

pi@raspberrypi:/opt/girder/qt/etc/xdg/Promixis $ ls -l
total 8

-rw-r--r-- 1 root root 126 Feb 28 19:47 Girder 6.ini

-rw-r--r-- 1 root root 127 Feb 28 19:10 pluginLicenses.conf


Thanks again for the help.

Ron
March 1st, 2017, 09:22 PM
pluginLicenses.conf should not contain your Girder key. Remove that from both files and see if it does the trick.

25TCP
March 1st, 2017, 09:41 PM
Thanks.

I removed both files and rebooted. Same result.


pi@raspberrypi:/opt/girder $ sudo ./Girder6Service
Girder License Path "/etc/xdg/Promixis/"

Should I not delete the plugLicenses.conf files but instead leave them there? If yes, what should their contents be?

UPDATE: I ran Girder6 front-end and it opens but... terminal gives me message:


libEGL warning: DRI2: failed to authenticate

Does that help?

Ron
March 1st, 2017, 11:10 PM
pluginLicenses.conf is not related to you licensing problem. Only Girder 6.ini should hold your key under "License" subsection. Email me (sales@promixis.com) your Girder 6.ini file and I'll have a look.