PDA

View Full Version : please help with power on



ppazera
August 2nd, 2003, 07:39 PM
Hi there,


Just assembled uirt2 using 16f84A-20i/2 @10MHz. Looks like everything works except power on. Tried FW 1.5-1.8, girder 3.1 & 3.2, tried sending setgpiocfg/getgpiocfg commands from hex terminal. It seems like pic doesn't hold information in data eeprom. Girder can control PB2 and other outputs. Getgpiocfg always returns all FFs, setgpiocfg usually gives 0x80 & 081 errors, but sometimes it returns 0x21. Although uirt2 doesn't respond to learned ir code, doesn't change pb2 or any other output with girder closed or PC powered off (+5V still supplied). What could be wrong? components I used? schematic? firmware? 16f84a?


Thanks,

Paulius

ppazera
August 4th, 2003, 03:26 AM
update after spending almost all weekend...

it looks like data eeprom issues. Changed code so it reads data from eeprom just after write and reports both values to host. It reads always 0xFF, no matter what I'm writing into it, no matter to which address. I got 16f84a as a sample from microchip TW directly - either they don't test samples (which I doubt) or I managed to fry data EEPROM somehow (how could this be possible???). So... will try to get another sample (and hope I won't need to spend another weekend :)

BTW, in order to avoid timeout errors while sending setGpioCfg commands to pic I had to increase timeout @0x025f in v1.8, made 0x30 instead of 0x14. That's probably trial terminal app issues I'm using but I'm reporting this just in case this is somehow related to 4/10MHz porting

ppazera
August 5th, 2003, 12:44 AM
ok, last update :)

those explanations were hard to believe so I did more google and one guy solved similar problem by adding 0.1uF bypass capacitor on +5V. I'm glad he posted it on internet, now everything works like a charm!