PDA

View Full Version : Y.A. Programming the UIRT2 Question



omargosh
March 17th, 2004, 01:37 AM
Been trying to update my UIRT2 to the latest firmware 1.8 from 1.4
http://users.skynet.be/sky50985/UIRT_10MHZ_1_8.zip

The programming (using uirt-dp.prog13.exe) seems to have been successful but when I use UIRT_test.exe and click on "GetVersion"
it returns

Rec:
01,04,FB;

So it appears that the update didn't take?

I tried several com ports, tried with 12volts & the 9 volt inline with 5 volt
trick, shorted out the 10Mhz crystal fo programming.

Why would the programmer uirt-dp.prog13.exe do a program/verify
successfully and yet I still see version 1.4?

Thanks,

Rick

error1
April 10th, 2004, 02:16 PM
The exact same thing happened here.

It appears the update went fine (program/verify) without errors.. But when i test it afterwards the version reply is the same as before.

So i have no idea wether it's upgraded or not.. But at least it still works!

Also, after much digging around on these forums i found that the three-pin serial cable that was recommended as a workaround for people with UIRTs that were unstable, will NOT work when programming the UIRT. You need a cable with all pins connected for that. Just thought i'd mention it since it took me so long to find out ;)