View Full Version : Problem with Hughes HR10-250 HD Tivo Remote and USB-UIRT

May 12th, 2004, 05:22 PM
I tried using the USB-UIRT plugin to learn the commands from the new Hughes HR10-250 HD Tivo satellite receiver, and ALMOST everything worked perfectly.

I could learn all buttons with one exception -- the "Enter" (also does Prev Ch) button in the bottom right corner of the remote.

The "signal" progress bar filled up, but the "learn" progress bar stopped a little less than halfway, and would not complete (whether I held down the button or pressed it repeatedly, from different distances, angles, etc). I even tried learning this button into an old Pronto (which worked -- from the Pronto), but when I pasted in the code from the Pronto, it was accepted, but did nothing. The Pronto code, though in HEX, did not appear to resemble the other button codes learned via USB-UIRT.

I even tried contacting Hughes/DirecTV, and after 3 hours reached someone in engineering who said she would check to determine whether this code (I told her I only needed one IR code, not the entire set) could be "released" to the public. I'm not too confident they will reveal it.

I even tried tweaking the USB-UIRT settings (speed, threshold, etc), but to no avail. I just can figure out why only this one button is causing problems.

Any ideas?

May 14th, 2004, 07:10 PM
Two things to try:

1. When pasting the Pronto code, make *sure* you're pasting it into the 'Import' dialog and *not* into the 'Code1/Code2' boxes (click Learn, then 'Import'). Also, when importing the code, make sure the 'Import as RAW' checkbox is CHECKED on the import dialog.

2. Alternatively, you can probably still learn the Enter button from your remote, but it probably doesn't complete normally because the remote is likely sending a single 'burst' for that command. The latest Girder plugins (www.usbuirt.com/latestGirderPlugin.zip) has an 'Accept Burst' button which will appear on the learn dialog after the progress bar fills up part way).


May 14th, 2004, 09:05 PM
Tried the Pronto paste again -- still didnt work.
But, once I downloaded the new plugin and used the "accept burst" feature, it worked like a charm.