PDA

View Full Version : Simpad Dead



dacostad
June 29th, 2004, 06:44 AM
I just got a simpad from ebay and while "exploring" it I ran the update which said it can take up to 5 mins, well after an hour I did a reset and that was the end.

I have tried all resets including hard and removing the battery and it will not come on.

Any ideas?

Thanks

Wilhelm
June 29th, 2004, 08:17 AM
Please tell us a little bit more: How did you update, how does "dead" look? What update did you use? Waht SIMPad do you have?...

You must be a little bit more specific to get usefull help.

dacostad
June 29th, 2004, 09:15 AM
Hi, yes I have the Simpad SL4 (grey and black)

I ran an update option that was on the start menu, I guess it was a Seimens option.

It downloaded the update and then started updating and said that it could take up to 5 mins, however it went on far longer.

I did a soft reset, but it would not boot up, I tried a few soft resets and both types of hard reset. I also removed the battery.

The simpad now simply does nothing, blank screen.

Hope that clarifies.

Thanks

Wilhelm
June 29th, 2004, 09:39 AM
... a bit.
Are you sure, the battery is not flat. Did you connect it to the AC-Adaptor before updateing or could it be the battery went down half way?
Does the display stay black? Does the Green LED light up when you switch it on?
If it's really a brick, then I can't help you from here. If there is a little bit of life left in it, you could reload the firmware with a serial connection. But for that it has at least to get power.

dacostad
June 29th, 2004, 08:22 PM
The battery (orange) charge light is on when connected to AC. THe display does stay black and the green light does not come on when I switch it on.


Thanks

David

Wilhelm
June 30th, 2004, 03:02 AM
Well, I don't exactly know, if the green LED is hardware or software controlled. You could try starting "serload.exe" and see if it gets any life out of it.
You can get a SIMPad image easily by downloading it form the edonkey network. Serload is included with the images.

I doubt that the internet-update function replaces the serial loader so it's worth a try.

dacostad
July 2nd, 2004, 11:10 PM
Hi again, I have a bit more information.

I connected the simpad to a PC and ran Hyperterminal. It seems to be in an endless loop and keeps saying;

"PBL V2.4 20.07.2001"

and it just keeps saying this.

If I try to serload a rom image it tells me to reset, but before I do anything it just starts saying the same thing as in hyperterminal.

Any ideas?

Thanks again

David

Wilhelm
July 3rd, 2004, 04:07 AM
Sorry David,

but unfortunately I'm also out of ideas now.
At least I can say, this serial message you are getting is not normal behaviour. My SIMPad does not send anything on the serial port when resetting it. (just checked)
I think you should contact Siemens and see what the are telling you. SIMPad's are guaranteed for 2 Years, so perhaps you are in luck.
I hope this works out.
The best of luck to you

Rob H
July 3rd, 2004, 04:19 AM
Have you got any PCMCIA cards installed? Try removing them and do the update again.

dacostad
July 3rd, 2004, 08:28 AM
Nope, no cards installed.

I think the bootloader is corrupt and therefore without using a JTAG to reload, I think I am screwed.

If anyone has a broken simpad (i.e. screen) but intact bootloader that they want to sell, please let me know.

Thanks


David