PDA

View Full Version : Generic serial port fails but Hyperterminal works



TAsheville
January 26th, 2005, 04:45 PM
Hi. First post on this forum. I'm using generic serial port 3.0.18 to connect Girder to a number of serial ports. I use a Digi multiport adapter which gets me up to COM18. I have several home theater components working well this way usign Girder. Recently, I hooked up my DWIN TV3+ projector which accepts simple ASCII commands ("[POFF]" = "power off"), but the Girder serial port won't work. HOWEVER, exactly the SAME configuration of port variables using Hyperterminal works fine. I have tried tweaking everything I can think of, like intracharacter delay, etc. without success. Any ideas? Thanks!!

Mark F
January 27th, 2005, 05:28 AM
Do you see any information coming from the TV3?

What is the handshaking setting? (HW/SW/Off)

Are you using the same cable with Hyperterminal?

TAsheville
January 27th, 2005, 10:16 AM
Thanks for the response, Mark. It is so amazing to be able to talk directly to the code's author. As best I can tell, the TV3+ is listen only. No response codes are listed in the manual. Even so, I tried various settings of the Receive dialog in the plugin, to no avail.

The port settings are 9600,N,8,1 with no handshaking. In fact, the serial calbe is a simple three wire TX,RX,GND connection, and yes, I make no changes in cabling between Girder and Hyperterminal.

I spoke to tech support at DWIN and they confirm that no additional line terminators are needed, and the device responds simplay to the "]" character on the end of a valid command, such as "[I3]" to "select input 3". And in fact, this is how the successful Hyperterminal interface functions.

A friend suggested that I hook the wire up to another port and "see" what exactly each program is sending. I'll try that this evening.

Thanks again for your attention to this problem!

TAsheville
January 27th, 2005, 06:57 PM
OK, I connected the cable to another COM port to see what Hyperterminal and the plugin are each sending to the DWIN projector. HT sent the ASCII thru without issue. The serial port plugin sent nothing. Hmmm... so I changed the text, and sure enough the plugin worked. So after some experimentation, here's what happens:

"POFF" works. "[POFF" works. "POFF]" works. "]POFF[" works. "[POFF]" does NOT work! Sends nothing. So an "[" followed by "]" somehow traps the entire string and sends nothing.

All the DWIN commands require a "[ ]" combination, so no commands work. Wierd!

Any ideas? Thanks!

Promixis
January 27th, 2005, 09:16 PM
the [] are used by girder to send a variable ie.

[variable]... so that is the problem... Note sure if we have a work around....

TAsheville
January 27th, 2005, 10:37 PM
Ouch! Bad luck! OK, well is it possible to load the bracketed commands in string variables, then send the variable? Where can I learn how to manipulate variables in Girder? Thanks!

Mark F
January 28th, 2005, 07:48 AM
Another possibility is to turn on the "Escape Sequences" in the transmit message definition. Then you can use a slash (/) and the hex code for [. (I think [ is hex 5B so try /5b)

Example: /5bPOFF]

TAsheville
January 28th, 2005, 09:18 AM
Great idea and that works! I REALLY appreciate your help!

Mark F
January 28th, 2005, 10:02 AM
Cool!

You and Mike figured out the problem, I'm just glad there was a relatively easy solution. :)