Page 15 of 15 FirstFirst ... 5131415
Results 141 to 149 of 149

Thread: Dallas Semiconductor one-wire plugin

  1. #141
    Join Date
    Jun 2009
    Posts
    11

    Default

    Just the sensors and a usb or rs232 1-wire adaptor. Im using the usb with no problems.

  2. #142
    Join Date
    May 2008
    Posts
    119

    Default

    Thanks for the info. Was wondering if I could use the usb hub.

  3. #143
    Join Date
    Jun 2005
    Posts
    760

    Default

    Quote Originally Posted by mhwlng View Post
    the 4.02beta driver from here doesn't seem to work propely (at least on my vista pc, ibfs32.dll is not installed)
    http://www.maxim-ic.com/products/ibu...tmex/index.cfm

    this older version works ok for me

    http://files.dalsemi.com/auto_id/lic...ivers_v400.msi
    I'm trying to migrate Girder to a Win-7 64-bit machine and things aren't going so well. The 4.02 drivers don't seem to install all the way but at least I got the Java I/F from the web-based help page to work so I'm getting close. The v400 drivers won't install on a 64-bit OS. In looking at the changes over the last five years, the biggest is the name change from "Dallas" to "Maxim" which means all the installation locations have changed to e.g. [HKEY_CURRENT_USER\SOFTWARE\Maxim Integrated Products\1-Wire Drivers], C:\Program Files\Maxim Integrated Products\1-Wire Drivers x64, etc.

    Marcel, I'm wondering if you've migrated to a 64-bit OS yourself and if that has translated to an updated 1-wire plugin and if not, if you have any plans to do so?

  4. #144
    Join Date
    Jan 2004
    Location
    The Netherlands
    Posts
    2,140

    Default

    If the Dallas/Maxim drivers don't work in a 64 bit os, then a new plugin won't be possible either..

    I don't use 1-wire much anymore anyway...
    just to control a few relays to open my front door and that can easily be changed to another technology (e.g. USB).

    Marcel

  5. #145
    Join Date
    Jun 2005
    Posts
    760

    Default

    Sorry I was half asleep and not very clear... The drivers do work because I was able to use Maxim's 1-wire Java-based viewer to see the devices on my network. However, I can't get your plugin to work. I assumed that might be because the driver file and registry entry locations have all changed. I don't know if that maters or not to your plugin which is why I asked.

  6. #146
    Join Date
    Jan 2004
    Location
    The Netherlands
    Posts
    2,140

    Default

    I don't know what maxim driver version you installed? only 4.00 will work...
    See my comments in the first post of this thread : version 4.02 doesn't work with the plugin.
    because the plugin uses the TMEX interface (which is not installed anymore by the most recent maxim drivers. The TMEX interface is handled by the maxim supplied ibfs32.dll)
    The java based viewer uses some other interface.
    I'm not planning any updates to the plugin, sorry...

    Marcel

  7. #147
    Join Date
    Jun 2005
    Posts
    760

    Default

    Yes, I saw your post about 4.02 not working because ibfs32.dll was not installed. In my case, the plugin seems to find it as I see this at startup:
    Code:
    Time	Date	Source	Details	Payloads
    21:04:39:379	12/29/2010	One-Wire Plugin	found IBFS32.DLL
    However, when I execute one of the plugin methods, I get this error in the Log Display:
    Code:
    Time	Date	Source	Details	Payloads
    21:05:13:839	12/29/2010	One-Wire Plugin	no devices found on 1-wire network
    21:05:13:839	12/29/2010	One-Wire Plugin	Could not read the default PortNum and PortType from registry
    Unfortunately, either the Maxim 1-wire utility that writes the port number/type registry entry doesn't work or the plugin is looking in a different location. Where does your plugin read the port settings? I'm wondering if it would work if I created registry keys at that location.

  8. #148
    Join Date
    Jan 2004
    Location
    The Netherlands
    Posts
    2,140

    Default

    The plugin doesn't read the registry. It just calls the TMEX function TMReadDefaultPort
    Apparently it fails on your system.
    I have no idea where this function gets the data from...

    Marcel

  9. #149
    Join Date
    Jun 2005
    Posts
    760

    Default

    OK, I'll explore the TMEX function.
    Thank you so much for your help Marcel.
    Happy New Year!

Page 15 of 15 FirstFirst ... 5131415

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •