Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43

Thread: Girder 3.2 alpha 1,2,....

  1. #1
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default Girder 3.2 alpha 1,2,....

    Well, as you might have seen I'm working on a new input event queue. Girder 3.2 has 3 goals:

    1. Fix the antirepeat problem
    2. Fix the input queue lenght
    3. Separate Core from UI

    1 and 2 are pretty much in, but have seen little testing, 3 is coming along pretty good, there are just a few more loose ends to tie before that is done aswell. A 4th goal is the NT server option, if this will make it into 3.2 is not yet sure.

    As always I need your help to find and squash the bugs, the more you help the faster you'll have Girder 3.2

    Disclaimer: don't use in a production environment yet.
    Ron
    No support through PM

  2. #2
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Quote Originally Posted by Snakebite
    I still have my antirepeat problem. In reality I'm holding down for 300ms or so but I have to set the timeout to 8000ms (longer than my command runs) for it to not repeat.
    Well I have no clue why this is, the antirepeat really works as advertised now, the event is timestamped when it enters Girder and compared to the old timestamp. Mind you, the antirepeat works on a per-action basis not on a per event basis maybe this is your mistake.
    Quote Originally Posted by Snakebite
    I noticed another thing. I'm using the same remote to control the volume on my amp, directly - not trough Girder. But still Girder registers the volumekey event and will beep the antirepeat/buffer full warning while I'm holding down to raise or lower the volume.
    Well of course girder will see this key if your irman sees it. I have no clue why it beeps though.
    Ron
    No support through PM

  3. #3
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Quote Originally Posted by Mark F
    The OSD Window (created by the OSD Popup plugin) doesn't seem to get the WM_TIMER message for it's timeout.
    You are not using the built in OSD right ? I mean girder is not responsible for the WM_TIMER thing.

    * checking the payload stuff.
    * checking the registercb stuff.
    Ron
    No support through PM

  4. #4
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    oh no that is bad news. That probably also means that the slinke plugin needs updating. Anyone feel like maintaining a plugin ( I'm not asking you Mark :-) you are busy enough )
    Ron
    No support through PM

  5. #5
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Yep that is broken

    [edit: and fixed :-) ]
    Ron
    No support through PM

  6. #6
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default Alpha 2

    Alpha 2 released it fixes:

    * Payload
    * EventCallback
    * Treepicker
    Ron
    No support through PM

  7. #7
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    PostMessage doesn't trigger any other actions. So that isn't the problem. Could you send me a simple file that demonstrates the problem.

    [edit] forget this, of course postmessage can trigger other commands.

    The commands that you trigger from an action plugin with a postmessage will not adhere to the anti-repeat. Which is the way it is supposed to be. Only events generated by a hardware plugin will go through the anti repeat check.

    Please give more information on the exact problem.
    Ron
    No support through PM

  8. #8
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Please also report version. I cannot reproduce any of your bugs in Alpha 2.

    What window are we talking about ?
    Ron
    No support through PM

  9. #9
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Matt, the alarmtimer problem is fixed, I have not seen the crash after the alarmtimer thing though. Can you send me an example when it crashes ?
    Ron
    No support through PM

  10. #10
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    I tested it,... it worked for me. Maybe you can send me the code so I can see what is going on.
    Ron
    No support through PM

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •