Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Getting Device Manager to show up

  1. #1
    Join Date
    Mar 2006
    Posts
    135

    Default Getting Device Manager to show up

    Hi Guys,

    Here are the contents of my Lua Console after disabling all plugins except HAI, Russound, Tree Script and Generic Serial and restarting Girder.

    hai work
    hai work
    Russound RNET - WORK 1.0.6
    ...am Files\Promixis\Girder\luascript\DeviceManager.lua: 123: attempt to call field `makeset' (a nil value)
    Welcome to Promixis Girder 4.0!

    Jim

  2. #2
    Join Date
    May 2004
    Location
    Cardigan, UK
    Posts
    9,278

    Default

    I'm guessing that you aren't using version 4.0.6 of Girder - that function should be in luascript\Additions.lua
    --Rob

  3. #3
    Join Date
    Mar 2006
    Posts
    135

    Default

    Nope....version 4.0.5.1

    I will update and let you know how it goes.

    Jim
    Last edited by jnickel; August 19th, 2006 at 01:19 PM.

  4. #4
    Join Date
    Mar 2006
    Posts
    135

    Default

    K....

    I updated to 4.0.6, resintalled the latest Russound plugin, resintalled the Device manager, started up Girder and now I get the device manager on the Automation panel ok, but I don't see any devices in the pulldown - it says, "No devices".

    So....I unchecked the Russound plugin, and exited Girder. Then I re-enabled it and I couldn't find it in the Serial list again. So I unchecked all the other plugins again except Russound, Serial, Treescript and HAI and then it was back in the serial list.

    I still can't choose Russound in the Device Manager though...it continues to say," No devices".

    Jim

  5. #5
    Join Date
    May 2004
    Location
    Cardigan, UK
    Posts
    9,278

    Default

    Any errors in the Lua console?
    --Rob

  6. #6
    Join Date
    Mar 2006
    Posts
    135

    Default

    I cleared the Lua console, exited Girder restarted and then went to Settings and then Device Manager, clicked ok and looked at the Lua console.

    Here is what it had:

    hai work
    hai work
    Russound RNET - WORK 1.0.6
    Remote Initialized
    No device type for Base
    Provider: X10 **** DM WARNING **** : X10 does not provide a function "MapControlsToCommands"
    Welcome to Promixis Girder 4.0!
    TreeScript (golua): ...Files\Promixis\Girder\/plugins/treescript/G2G UI.lua:196: attempt to index global `g2g' (a nil value)
    stack traceback:
    ...Files\Promixis\Girder\/plugins/treescript/G2G UI.lua:196: in function <...Files\Promixis\Girder\/plugins/treescript/G2G UI.lua:195>
    client table error: NetRemote not enabled
    TreeScript (golua): ...Promixis\Girder\/plugins/treescript/NetRemote UI.lua:79: attempt to concatenate field `Version' (a nil value)
    stack traceback:
    ...Promixis\Girder\/plugins/treescript/NetRemote UI.lua:79: in function <...Promixis\Girder\/plugins/treescript/NetRemote UI.lua:48>
    ...Promixis\Girder\/plugins/treescript/NetRemote UI.lua:102: in function <...Promixis\Girder\/plugins/treescript/NetRemote UI.lua:101>

    Jim

  7. #7
    Join Date
    May 2004
    Location
    Cardigan, UK
    Posts
    9,278

    Default

    Okay, that's a bit strange - the errors aren't anything to worry about, you just don't have the g2g and NetRemote plugins enabled.

    This is probably one for Mike to deal with since he wrote the Russound plugin.

    What model of RussSound do you have?

    It may be worth editing DeviceManager.lua to set the LogLevel to 0 for the full DM logging experience.
    --Rob

  8. #8
    Join Date
    Mar 2006
    Posts
    135

    Default

    Actually it is a bit of a concern for me as none of my stuff works now and
    I do have the Netremote plugin enabled.

    I never disabled it as you enable/disable it from the Automation panel and not with the other plugins. I double checked just now that it is enabled, and it is.

    I have the Russound CAM 6.6T with UNO-S1 keypads.

    Jim
    Last edited by jnickel; August 19th, 2006 at 04:11 PM.

  9. #9
    Join Date
    May 2004
    Location
    Cardigan, UK
    Posts
    9,278

    Default

    Can you check the comments of the file NetRemote.lua in girder\luascript - what version does it claim to be?
    --Rob

  10. #10
    Join Date
    Mar 2006
    Posts
    135

    Default

    Says version 0.32

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •