Results 1 to 5 of 5

Thread: Disabling / Enabling Components

  1. #1
    Join Date
    Nov 2003
    Location
    Hove, E Sussex, UK
    Posts
    4,005

    Default Disabling / Enabling Components

    Hi Chaps.

    I have just tried to disable a component "Sun Clock" from the component manager, I had Custom Weather and the Sun Clock Enabled.

    I selected Sun Clock, hit diable and it removed Custom Weather, and left Sun Clock in the list. So I selected sun clock again, hit disable and got the following in the console.

    TreeScript (golua): ...omixis\Girder5\luascript\Components/Classes/Base.lua:113: assertion failed!
    stack traceback:
    [C]: in function `assert'
    ...omixis\Girder5\luascript\Components/Classes/Base.lua:113: in function `Disable'
    ...mixis\Girder5\luascript\components\CustomWeathe r.lua:101: in function `Disable'
    ...iles\Promixis\Girder5\luascript\ComponentManage r.lua:243: in function `DisableComponent'
    ...\Girder5\/plugins/treescript/ComponentManager UI.lua:144: in function <...\Girder5\/plugins/treescript/ComponentManager UI.lua:117>
    When I restarted girder both were not enabled.
    Last edited by danward79; September 29th, 2006 at 02:14 PM.
    Thx, Dan

    Onwards and Upwards!
    http://www.danward.co.uk

  2. #2
    Join Date
    Nov 2003
    Location
    Hove, E Sussex, UK
    Posts
    4,005

    Default

    Another error I get is this when I select wmi to be enabled.

    TreeScript (golua): COM exception.\src\library\tLuaCOM.cpp,394):Invalid class
    stack traceback:
    [C]: in function `AddEnum'
    ...ram Files\Promixis\Girder5\luascript\Classes/WMI.lua:43: in function `Connect'
    ... Files\Promixis\Girder5\luascript\components\WMI.lu a:44: in function `Initialize'
    ...iles\Promixis\Girder5\luascript\ComponentManage r.lua:232: in function `EnableComponent'
    ...\Girder5\/plugins/treescript/ComponentManager UI.lua:132: in function <...\Girder5\/plugins/treescript/ComponentManager UI.lua:117>
    Thx, Dan

    Onwards and Upwards!
    http://www.danward.co.uk

  3. #3
    Join Date
    Dec 2001
    Posts
    11,560

    Default

    The enable/disable should be fixed in the next release.


    The WMI error suggests something wrong with your WMI install

  4. #4
    Join Date
    Nov 2003
    Location
    Hove, E Sussex, UK
    Posts
    4,005

    Default

    Ah you could be right there, I may have disabled the service! Thanks for the info, so far I have had no g5 errors or crashes.
    Thx, Dan

    Onwards and Upwards!
    http://www.danward.co.uk

  5. #5
    Join Date
    Nov 2003
    Location
    Hove, E Sussex, UK
    Posts
    4,005

    Default

    One thing that would be good, on the note of the vmi error Mike, would be if it had a more graceful message in the logger?
    Thx, Dan

    Onwards and Upwards!
    http://www.danward.co.uk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •