Page 8 of 10 FirstFirst ... 678910 LastLast
Results 71 to 80 of 96

Thread: Driver for RFXmitter by RFXCOM released

  1. #71
    Join Date
    Jul 2007
    Location
    Netherlands
    Posts
    370

    Default

    Quote Originally Posted by Solosid View Post
    Hi Tieske,

    Can i simply configure to a new virtual com port?

    say port 21 and 22?

    Cheers

    Mark
    That would be the quickest route I guess. Define a new virtual COM port, then test with the RFXmitter.exe test program. If that works, shutdown the RFXmitter.exe test program, start Girder and reconfigure the RFXmitter driver on the 'serial' tab to the new virtual COM port.
    You should then also check the Girder eventlog and lua console for messages of some other device that still tries to connect to the COM12 port, that would then be the device that creates the conflict.
    Using: Win7 MCE, Girder, xPL, RFXcom, HomeEasy

    http://www.thijsschreijer.nl

  2. #72
    Join Date
    Mar 2008
    Location
    Nottingham, England
    Posts
    406

    Default

    Hi Tieske,

    It didnt work changing the com ports, it didn't even show up in the rfxmitter program.
    I only had a brief chance to play as I'm out of the country working for a week.
    Just thought I'd keep you posted

    Cheers
    Mark
    some people learn by writing, some by reading, some by listening and some by doing?...me I'm not learning at all

  3. #73
    Join Date
    Jul 2007
    Location
    Netherlands
    Posts
    370

    Default

    Quote Originally Posted by Solosid View Post
    It didnt work changing the com ports, it didn't even show up in the rfxmitter program.
    Thats correct, hadn't thought about that. The rfxmitter program only scans the first 20 ports, so to make it work you could use anything from COM1 to COM20, anything beyond that will not be shown.
    Using: Win7 MCE, Girder, xPL, RFXcom, HomeEasy

    http://www.thijsschreijer.nl

  4. #74
    Join Date
    Mar 2008
    Location
    Nottingham, England
    Posts
    406

    Default

    Hi Tieske,

    Back now after working out of the Country.

    I have changed the com ports to Com15 for the Reciever on port 10001
    and Com16 for the Xmitter on port 10002

    I can use the supplied programs perfectly including the heater.

    I still get the same problem in Girder with the in log as

    Time Date Source Details Payloads
    14:59:47:068 8/13/2010 RFXmitter Driver version 0.2. Initialization command failed: Codes returned (40 00): NORESPONSETIMEOUT


    cheers

    Mark
    Last edited by Solosid; August 13th, 2010 at 09:01 AM. Reason: spelling mistake
    some people learn by writing, some by reading, some by listening and some by doing?...me I'm not learning at all

  5. #75
    Join Date
    Mar 2008
    Location
    Nottingham, England
    Posts
    406

    Default

    Hi Tieske,

    got this reply in the log today...
    Time Date Source Details Payloads
    00:01:41:369 8/15/2010 RFXmitter Driver version 0.2. Initialization command failed: Data received (1 bytes): 30.Codes returned (01 00 00):


    slightly different from log previous?

    Cheers

    Mark
    some people learn by writing, some by reading, some by listening and some by doing?...me I'm not learning at all

  6. #76
    Join Date
    Jul 2007
    Location
    Netherlands
    Posts
    370

    Default

    Quote Originally Posted by Tieske8 View Post
    Mark,
    Quote Originally Posted by Tieske8 View Post
    Mark,

    I've been thinking this over and it gets harder and harder to pinpoint a cause of this error.

    From what I saw in the screenshot you posted (and removed again), you have the RFXmitter program connected to COM12. And it was working, eg. you were able to turn lights on/off.

    One thing not yet covered is other Girder devices. So can you run some tests;
    1) remove the RFXMitter from Girder (in the serial tab, remove it) and close Girder
    2) start RFXmitter and make sure you can switch a light on/off
    3) close rfxmitter (so it releases COM12), start Girder but don't do anything. Now start RFXmitter again and see if you can again switch a light on/off on COM12. With Girder in the background, just to make sure that some other Girder component doesn't grab COM12.
    Its important to run the sequence exactly in the order described.
    I didn't see an explicit answer on this one; have you tried it and what are the results?
    What where the results of this? from your last two posts, its clear that you still have the rfxmitter driver in Girder enabled...
    Have you run the test in this order?
    Using: Win7 MCE, Girder, xPL, RFXcom, HomeEasy

    http://www.thijsschreijer.nl

  7. #77
    Join Date
    Mar 2008
    Location
    Nottingham, England
    Posts
    406

    Default

    Hi Tieske,

    I did reply...see post 66.

    The last two posts refered to changing the Com ports to 15 and 16.

    I have tried again with the Xmitter configured to Com 16 and I can still control my HomeEasy stuff with the RFXmitter program when girder is running with the Com port released.

    I hope this helps....

    I feel were getting closer!


    Cheers

    Mark
    some people learn by writing, some by reading, some by listening and some by doing?...me I'm not learning at all

  8. #78
    Join Date
    Mar 2008
    Location
    Nottingham, England
    Posts
    406

    Default

    Hi Tieske,

    Can i try this setup on a laptop with wireless,

    ie. install girder, port redirector, the plugin on the wireless to see if I get the same message?


    OR

    would any kind of firewall issue be stopping girder from connecting to the RXFcom unit, even though I can use the supplied program.


    Cheers

    Mark
    some people learn by writing, some by reading, some by listening and some by doing?...me I'm not learning at all

  9. #79
    Join Date
    Jul 2007
    Location
    Netherlands
    Posts
    370

    Default

    Mark,

    I can reproduce the error you're getting. Bert setup some test equipment that I'm now adressing over the internet, using the CPR.
    With th RFXmitter program I get results as expected, with Girder I don't.

    I'm investigating, will get back when I know more.
    Using: Win7 MCE, Girder, xPL, RFXcom, HomeEasy

    http://www.thijsschreijer.nl

  10. #80
    Join Date
    Mar 2008
    Location
    Nottingham, England
    Posts
    406

    Default

    Hi Tieske,

    Thanks for getting back to me.

    I am relocating my Rack so I might be unable to test for a week or so.

    Cheers

    Mark
    some people learn by writing, some by reading, some by listening and some by doing?...me I'm not learning at all

Page 8 of 10 FirstFirst ... 678910 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •